summaryrefslogtreecommitdiff
path: root/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
commitf287ecad888abdeb38e617d0485de282cd6819db (patch)
tree874d56500040734c4dbb9e437e0d5ed80a0a1886 /dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
parent844ae757702c53a56ee57056873a8204d256d47e (diff)
gentoo auto-resync : 19:12:2022 - 19:49:08
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
deleted file mode 100644
index fc1b4b73bd0a..000000000000
--- a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
- inherit git-r3
- S="${WORKDIR}/${P}/src"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCR-Runtime-rocm-${PV}/src"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Radeon Open Compute Runtime"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
-PATCHES=(
- "${FILESDIR}/${PN}-4.1.0-cmake-install-paths.patch"
- "${FILESDIR}/${PN}-4.3.0_no-aqlprofiler.patch"
-)
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-
-COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/roct-thunk-interface-${PV}
- >=dev-libs/rocm-device-libs-${PV}"
-BDEPEND="app-editors/vim-core"
- # vim-core is needed for "xxd"
-
-src_prepare() {
- # ... otherwise system llvm/clang is used ...
- sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS ${EPREFIX}/usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
-
- # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
- sed -e "s:/opt/rocm/amdgcn/bitcode:${EPREFIX}/usr/lib/amdgcn/bitcode:" -i image/blit_src/CMakeLists.txt || die
-
- cmake_src_prepare
-}