summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild')
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild b/dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild
new file mode 100644
index 000000000000..5b3f588b3d54
--- /dev/null
+++ b/dev-libs/rocm-comgr/rocm-comgr-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/comgr"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-rocm-${PV}/lib/comgr"
+ KEYWORDS="~amd64"
+fi
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.0-dependencies.patch"
+)
+
+DESCRIPTION="Radeon Open Compute Code Object Manager"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocm-device-libs-${PV}
+ >=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLD_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/lld"
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
+ -DClang_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/clang"
+ )
+ cmake_src_configure
+}