summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild')
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild b/dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild
deleted file mode 100644
index e357310f2535..000000000000
--- a/dev-libs/rocm-comgr/rocm-comgr-2.7.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
- inherit git-r3
- S="${WORKDIR}/${P}/lib/comgr"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/comgr"
- KEYWORDS="~amd64"
-fi
-PATCHES=(
- "${FILESDIR}/${PN}-2.6.0-correctly-install.patch"
- "${FILESDIR}/${PN}-2.6.0-find-clang.patch"
- "${FILESDIR}/${PN}-2.6.0-find-lld-includes.patch"
- "${FILESDIR}/${PN}-2.6.0-dependencies.patch"
- "${FILESDIR}/${PN}-2.6.0-unbundle-yaml-cpp.patch"
- "${FILESDIR}/${PN}-2.7.0-llvm-interface-change.patch"
-)
-
-DESCRIPTION="Radeon Open Compute Code Object Manager"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-
-RDEPEND=">=dev-libs/rocm-device-libs-${PV}
- dev-cpp/yaml-cpp:=
- >=sys-devel/llvm-roc-${PV}:="
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- rm -rf yaml-cpp || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
- )
- cmake-utils_src_configure
-}