summaryrefslogtreecommitdiff
path: root/dev-libs/rlog/rlog-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
commit618c3037024b4e5328531cdc07c6ceb7486f5329 (patch)
tree7c9f8d50c6f5fbd53f3df583c471f5d2e5c34202 /dev-libs/rlog/rlog-1.4.ebuild
parent76dfef0cec9170000357d2f354e412daf48941fc (diff)
gentoo resync : 31.12.2017 (final resync this year)
Diffstat (limited to 'dev-libs/rlog/rlog-1.4.ebuild')
-rw-r--r--dev-libs/rlog/rlog-1.4.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/dev-libs/rlog/rlog-1.4.ebuild b/dev-libs/rlog/rlog-1.4.ebuild
index c24fabb7a48c..0a937d761f36 100644
--- a/dev-libs/rlog/rlog-1.4.ebuild
+++ b/dev-libs/rlog/rlog-1.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
+
+inherit autotools
DESCRIPTION="A C++ logging library"
HOMEPAGE="http://www.arg0.net/rlog"
@@ -13,11 +14,19 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc sparc x86"
IUSE=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
+ "${FILESDIR}"/${PN}-1.4-fix-build-system.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
+ default
+ eautoreconf
}
src_install() {
- emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
- dodoc AUTHORS ChangeLog README
+ default
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
}