summaryrefslogtreecommitdiff
path: root/dev-libs/rlog/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/rlog/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/rlog/files')
-rw-r--r--dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch10
-rw-r--r--dev-libs/rlog/files/rlog-1.4-fix-build-system.patch59
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
new file mode 100644
index 000000000000..07770791cd77
--- /dev/null
+++ b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- a/rlog/RLogChannel.cpp
++++ b/rlog/RLogChannel.cpp
+@@ -20,6 +20,7 @@
+ #include "RLogChannel.h"
+ #include "rlog.h"
+ #include "Lock.h"
++#include <cstring>
+
+ using namespace std;
+ using namespace rlog;
diff --git a/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..b7959a79cd02
--- /dev/null
+++ b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
@@ -0,0 +1,59 @@
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -1,15 +1,13 @@
+
+ SOURCES = index.dox channel.dox component.dox
+
+-docdir = $(datadir)/doc
+-pkgdocdir = $(docdir)/$(PACKAGE)
+ #pkghtmldir = $(pkgdocdir)/html
+
+
+ # have both html and html/index.html to force build of index.html if necessary
+ EXTRA_DIST = latex/refman.pdf html html/index.html $(SOURCES)
+
+-pkgdoc_DATA = \
++pdf_DATA = \
+ latex/refman.pdf
+
+ #pkghtml_DATA = \
+@@ -17,22 +15,21 @@
+
+ if BUILD_DOCS
+ latex/refman.pdf: html/index.html
+- -cd latex && make
++ $(MAKE) -C latex
+
+ html/index.html: ../Doxyfile $(SOURCES)
+- -rm -rf html
+- -cd .. && @DOXYGEN@ Doxyfile
++ rm -rf html && $(DOXYGEN) Doxyfile
+
+ clean-local:
+- -rm -rf html
+- -rm -rf latex
++ rm -rf html
++ rm -rf latex
+ endif
+
+ all-local: html/index.html
+
+-install-data-local: all-local
+- -echo installing to ${DESTDIR}${pkgdocdir}/html
+- /bin/sh ../mkinstalldirs ${DESTDIR}${pkgdocdir}/html
+- install html/* ${DESTDIR}${pkgdocdir}/html
++install-data-hook: all-local
++ -echo installing to $(DESTDIR)$(htmldir)
++ /bin/sh ../mkinstalldirs $(DESTDIR)$(htmldir)
++ install html/* $(DESTDIR)$(htmldir)
+
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,6 +10,3 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = librlog.pc
+
+-documentation:
+- cd docs && make
+-