summaryrefslogtreecommitdiff
path: root/dev-libs/redland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-libs/redland
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-libs/redland')
-rw-r--r--dev-libs/redland/Manifest1
-rw-r--r--dev-libs/redland/redland-1.0.17-r2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/redland/Manifest b/dev-libs/redland/Manifest
index 8693105186ce..1fd8479f0728 100644
--- a/dev-libs/redland/Manifest
+++ b/dev-libs/redland/Manifest
@@ -1,3 +1,4 @@
DIST redland-1.0.17.tar.gz 1621566 BLAKE2B ec94cd456a771b97ab16fab63cf6beffe1ce3371c06213faa49162fe452b31a21dffe6c2cc631c10b137f44dc71c2c40c1d7fac0552bbe0169728427b1f47a36 SHA512 363323ffc9e75d4f0e3a3b40952f6241fd0d8b9f46bfd4dd86cf0a5162de35257a8b70ce408a6083c03ba7c388982231a3774e5e9024b262ebb02968f778b850
EBUILD redland-1.0.17-r1.ebuild 2464 BLAKE2B bed3fcba31401116c045a440fb1aab2196c25ad3070eaf0a11683087fea07d0e6998c612c034c6bfefeff5adbc12b87c69ef207585fbff9f2880aaf775ddf249 SHA512 f2975cf0c971b53381f5a7fbd54292812a2bdc8e96982069ede430de93b174c27f2404b26209aa45ebf6c15d1ee545cf78fa03f241f34a3e8b01b49fd25e9258
+EBUILD redland-1.0.17-r2.ebuild 2508 BLAKE2B 0a9f5459c00966eb6f5bba76c181076b0f99fb0d75c3848c8361cdd093577e4424f5285ac0ef176c1919302c6b0a844779c2b7819bbe15e2397d97866d059625 SHA512 b055d44068344f1d37cab1bc16a736d315556c124ce87d87b5bbe494780fbf4f0764ec9a234d160d178b88b673a12f2bde9c4653df41aa3138f2d933969725d6
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/dev-libs/redland/redland-1.0.17-r2.ebuild b/dev-libs/redland/redland-1.0.17-r2.ebuild
new file mode 100644
index 000000000000..1f2d86face16
--- /dev/null
+++ b/dev-libs/redland/redland-1.0.17-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit db-use libtool
+
+DESCRIPTION="High-level interface for the Resource Description Framework"
+HOMEPAGE="http://librdf.org/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="berkdb iodbc mysql odbc postgres sqlite static-libs"
+
+RDEPEND="dev-libs/libltdl:0
+ mysql? ( dev-db/mysql-connector-c:0= )
+ sqlite? ( =dev-db/sqlite-3* )
+ berkdb? ( sys-libs/db )
+ >=media-libs/raptor-2.0.14
+ >=dev-libs/rasqal-0.9.32
+ postgres? ( dev-db/postgresql )
+ iodbc? ( dev-db/libiodbc )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1" #500574, required for both src_compile() and src_install()
+
+src_prepare() {
+ default
+ elibtoolize # NOTE: this is for fbsd .so version
+}
+
+src_configure() {
+ local myconf=( --without-virtuoso )
+ if use iodbc; then
+ myconf=( --with-virtuoso --with-iodbc --without-unixodbc )
+ elif use odbc; then
+ myconf=( --with-virtuoso --with-unixodbc --without-iodbc )
+ fi
+
+ if use berkdb; then
+ myconf+=(
+ --with-bdb-include="$(db_includedir)"
+ --with-bdb-lib="${EPREFIX}"/usr/$(get_libdir)
+ --with-bdb-dbname="$(db_libname)"
+ )
+ fi
+
+ # FIXME: upstream doesn't test with --with-threads and testsuite fails
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with berkdb bdb) \
+ $(use_with mysql) \
+ $(use_with sqlite) \
+ $(use_with postgres postgresql) \
+ --without-threads \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ "${myconf[@]}"
+}
+
+src_test() {
+ if ! use berkdb; then
+ export REDLAND_TEST_CLONING_STORAGE_TYPE=hashes
+ export REDLAND_TEST_CLONING_STORAGE_NAME=test
+ export REDLAND_TEST_CLONING_STORAGE_OPTIONS="hash-type='memory',dir='.',write='yes',new='yes',contexts='yes'"
+ fi
+ default
+}
+
+src_install() {
+ default
+ docinto html
+ dodoc {FAQS,NEWS,README,RELEASE,TODO}.html
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+
+ # !!! REMOVE THIS ON VERSION BUMP, see bug 468298 for proper fix !!!
+ if [[ -n ${LDFLAGS} ]]; then
+ sed -i \
+ -e "s:${LDFLAGS} ::g" \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/${PN}.pc || die
+ fi
+
+ # https://bugs.gentoo.org/467768
+ local _rdocdir=/usr/share/doc/${PF}/html/${PN}
+ [[ -d ${ED}/${_rdocdir} ]] && dosym ${_rdocdir} /usr/share/gtk-doc/html/${PN}
+}