summaryrefslogtreecommitdiff
path: root/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch')
-rw-r--r--dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch b/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
new file mode 100644
index 000000000000..bdc720e8cf86
--- /dev/null
+++ b/dev-libs/rapidjson/files/rapidjson-1.1.0-system_gtest.patch
@@ -0,0 +1,44 @@
+--- /CMakeModules/FindGTestSrc.cmake
++++ /CMakeModules/FindGTestSrc.cmake
+@@ -1,30 +1,9 @@
+-
+-SET(GTEST_SEARCH_PATH
+- "${GTEST_SOURCE_DIR}"
+- "${CMAKE_CURRENT_LIST_DIR}/../thirdparty/gtest/googletest")
+-
+-IF(UNIX)
+- IF(RAPIDJSON_BUILD_THIRDPARTY_GTEST)
+- LIST(APPEND GTEST_SEARCH_PATH "/usr/src/gtest")
+- ELSE()
+- LIST(INSERT GTEST_SEARCH_PATH 1 "/usr/src/gtest")
+- ENDIF()
+-ENDIF()
+-
+-FIND_PATH(GTEST_SOURCE_DIR
+- NAMES CMakeLists.txt src/gtest_main.cc
+- PATHS ${GTEST_SEARCH_PATH})
+-
+-
+ # Debian installs gtest include directory in /usr/include, thus need to look
+ # for include directory separately from source directory.
+ FIND_PATH(GTEST_INCLUDE_DIR
+ NAMES gtest/gtest.h
+- PATH_SUFFIXES include
+- HINTS ${GTEST_SOURCE_DIR}
+- PATHS ${GTEST_SEARCH_PATH})
++ PATH_SUFFIXES include)
+
+ INCLUDE(FindPackageHandleStandardArgs)
+ find_package_handle_standard_args(GTestSrc DEFAULT_MSG
+- GTEST_SOURCE_DIR
+ GTEST_INCLUDE_DIR)
+--- /test/CMakeLists.txt
++++ /test/CMakeLists.txt
+@@ -8,7 +8,6 @@
+ set(gtest_force_shared_crt ON)
+ endif()
+
+- add_subdirectory(${GTEST_SOURCE_DIR} ${CMAKE_BINARY_DIR}/googletest)
+ include_directories(SYSTEM ${GTEST_INCLUDE_DIR})
+
+ set(TEST_LIBRARIES gtest gtest_main)