summaryrefslogtreecommitdiff
path: root/dev-libs/quazip/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-libs/quazip/files
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-libs/quazip/files')
-rw-r--r--dev-libs/quazip/files/quazip-1.1-conditional-tests.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch b/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch
new file mode 100644
index 000000000000..68520a4b3b9d
--- /dev/null
+++ b/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch
@@ -0,0 +1,40 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 14230a6..22c1421 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,34 +26,25 @@ set(QUAZIP_LIB_FILE_NAME quazip${QuaZip_VERSION_MAJOR}-qt${QUAZIP_QT_MAJOR_VERSI
+ set(QUAZIP_LIB_TARGET_NAME QuaZip)
+ set(QUAZIP_DIR_NAME QuaZip-Qt${QUAZIP_QT_MAJOR_VERSION}-${QUAZIP_LIB_VERSION})
+ set(QUAZIP_PACKAGE_NAME QuaZip-Qt${QUAZIP_QT_MAJOR_VERSION})
+-set(QUAZIP_ENABLE_TESTS OFF)
++option(QUAZIP_ENABLE_TESTS "" OFF)
+ if(QUAZIP_QT_MAJOR_VERSION EQUAL 6)
+ find_package(Qt6 REQUIRED COMPONENTS Core Core5Compat
+ OPTIONAL_COMPONENTS Network Test)
+ set(QUAZIP_LIB_QT_LIBRARIES Qt6::Core Qt6::Core5Compat)
+ set(QUAZIP_TEST_QT_LIBRARIES Qt6::Core Qt6::Core5Compat Qt6::Network Qt6::Test)
+ set(QUAZIP_PKGCONFIG_REQUIRES Qt6Core)
+- if (Qt6Network_FOUND AND Qt6Test_FOUND)
+- set(QUAZIP_ENABLE_TESTS ON)
+- endif()
+ elseif(QUAZIP_QT_MAJOR_VERSION EQUAL 5)
+ find_package(Qt5 REQUIRED COMPONENTS Core
+ OPTIONAL_COMPONENTS Network Test)
+ set(QUAZIP_LIB_QT_LIBRARIES Qt5::Core)
+ set(QUAZIP_TEST_QT_LIBRARIES Qt5::Core Qt5::Network Qt5::Test)
+ set(QUAZIP_PKGCONFIG_REQUIRES Qt5Core)
+- if (Qt5Network_FOUND AND Qt5Test_FOUND)
+- set(QUAZIP_ENABLE_TESTS ON)
+- endif()
+ elseif(QUAZIP_QT_MAJOR_VERSION EQUAL 4)
+ find_package(Qt4 4.5.0 REQUIRED COMPONENTS QtCore
+ OPTIONAL_COMPONENTS QtNetwork QtTest)
+ set(QUAZIP_LIB_QT_LIBRARIES Qt4::QtCore)
+ set(QUAZIP_TEST_QT_LIBRARIES Qt4::QtCore Qt4::QtNetwork Qt4::QtTest)
+ set(QUAZIP_PKGCONFIG_REQUIRES QtCore)
+- if (QT_QTNETWORK_FOUND AND QT_QTTEST_FOUND)
+- set(QUAZIP_ENABLE_TESTS ON)
+- endif()
+ else()
+ message(FATAL_ERROR "Qt version ${QUAZIP_QT_MAJOR_VERSION} is not supported")
+ endif()