summaryrefslogtreecommitdiff
path: root/dev-libs/qof/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/qof/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/qof/files')
-rw-r--r--dev-libs/qof/files/qof-0.8.8-cflags.patch36
-rw-r--r--dev-libs/qof/files/qof-0.8.8-unistd-define.patch58
-rw-r--r--dev-libs/qof/files/qof-0.8.8-unittest.patch44
-rw-r--r--dev-libs/qof/files/qof-0.8.8-yacc-build.patch69
4 files changed, 207 insertions, 0 deletions
diff --git a/dev-libs/qof/files/qof-0.8.8-cflags.patch b/dev-libs/qof/files/qof-0.8.8-cflags.patch
new file mode 100644
index 000000000000..27d2172c7616
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-cflags.patch
@@ -0,0 +1,36 @@
+From 1c56fc78f2a04625ae8c3aebd55236556ce28a90 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:04:24 +0100
+Subject: [PATCH 1/2] Remove some CFLAGS
+
+* Debugging level is only useful for debugging.
+* Werror is taken care of in error-on-warning configure switch.
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b38da9b..d80e7e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -393,7 +393,7 @@ dnl # *************************************
+ AC_MSG_CHECKING(what extra warning flags to pass to the C compiler)
+ if test ${GCC}x = yesx; then
+ warnFLAGS=
+- CFLAGS="${CFLAGS} -g2 -Wall"
++ CFLAGS="${CFLAGS} -Wall"
+ AC_ARG_ENABLE(error-on-warning,
+ [ --disable-error-on-warning
+ disable treating compile warnings as errors],
+@@ -431,7 +431,7 @@ AC_ARG_ENABLE(compile-warnings,
+
+ if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
+ warnFLAGS="$warnFLAGS -Wcast-align -Wsign-compare \
+- -Wmissing-prototypes -Wmissing-declarations -Werror -Wmissing-include-dirs \
++ -Wmissing-prototypes -Wmissing-declarations -Wmissing-include-dirs \
+ -Wstrict-prototypes -Winline -Wnested-externs -Wpointer-arith \
+ -Wmissing-field-initializers"
+ # LDFLAGS="$LDFLAGS -Wl,-z,defs"
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-unistd-define.patch b/dev-libs/qof/files/qof-0.8.8-unistd-define.patch
new file mode 100644
index 000000000000..c76afadb6584
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-unistd-define.patch
@@ -0,0 +1,58 @@
+From f2504eacb6d5e42b28df77041ff659fded3fd1a4 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:43:31 +0100
+Subject: [PATCH 3/5] Leave yacc defines to configure
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Resulted in:
+* QA Notice: Package triggers severe warnings which indicate that it
+* may exhibit random runtime failures.
+* lexer.c:1942:9: warning: implicit declaration of function ‘isatty’
+* [-Wimplicit-function-declaration]
+---
+ configure.ac | 2 ++
+ lib/libsql/lexer.l | 2 ++
+ lib/libsql/sql_parser.h | 1 -
+ 3 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d80e7e5..30ea37a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -52,6 +52,8 @@ AC_PROG_MAKE_SET
+ AC_FUNC_MKTIME
+ AC_FUNC_STRTOD
+
++AC_CHECK_HEADERS_ONCE([unistd.h])
++
+ dnl # *****************************************
+ dnl # pkg-config check time
+ dnl # *****************************************
+diff --git a/lib/libsql/lexer.l b/lib/libsql/lexer.l
+index fa8c5d1..44d65e8 100644
+--- a/lib/libsql/lexer.l
++++ b/lib/libsql/lexer.l
+@@ -1,4 +1,6 @@
+ %{
++#include <config.h>
++
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/lib/libsql/sql_parser.h b/lib/libsql/sql_parser.h
+index 2157e5c..0eba93f 100644
+--- a/lib/libsql/sql_parser.h
++++ b/lib/libsql/sql_parser.h
+@@ -2,7 +2,6 @@
+ #define SQL_PARSER_H
+
+ #include <glib.h>
+-#define YY_NO_UNISTD_H
+
+
+ typedef struct sql_statement sql_statement;
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-unittest.patch b/dev-libs/qof/files/qof-0.8.8-unittest.patch
new file mode 100644
index 000000000000..070c37ead255
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-unittest.patch
@@ -0,0 +1,44 @@
+From 21315eb014eb908ce3472fa75917412e21fcea29 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:06:39 +0100
+Subject: [PATCH 2/2] Make unittest build on demand
+
+Unittests need not be built when not run.
+Also, solves a dependency problem where libqofsql would not be built
+before sql_backend_test is linked.
+
+https://bugs.gentoo.org/show_bug.cgi?id=197999
+---
+ lib/libsql/Makefile.am | 2 +-
+ qof/test/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/libsql/Makefile.am b/lib/libsql/Makefile.am
+index b410689..c9534fb 100644
+--- a/lib/libsql/Makefile.am
++++ b/lib/libsql/Makefile.am
+@@ -21,7 +21,7 @@ libqofsql_la_LIBADD = ${GLIB_LIBS}
+ qofsqlincludedir = ${pkgincludedir}
+ qofsqlinclude_HEADERS = sql_parser.h
+
+-noinst_PROGRAMS = sql_parse_test
++check_PROGRAMS = sql_parse_test
+
+ EXTRA_DIST = \
+ README \
+diff --git a/qof/test/Makefile.am b/qof/test/Makefile.am
+index da7f28f..0760f45 100644
+--- a/qof/test/Makefile.am
++++ b/qof/test/Makefile.am
+@@ -65,7 +65,7 @@ test_sql_SOURCES = \
+ test-stuff.c \
+ test-sql.c
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-book-merge \
+ test-date \
+ test-guid \
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-yacc-build.patch b/dev-libs/qof/files/qof-0.8.8-yacc-build.patch
new file mode 100644
index 000000000000..cb4f9a9c0d07
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-yacc-build.patch
@@ -0,0 +1,69 @@
+From 118b7287f776b789a7c122f7c7e8a1cc1084e15e Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 13:01:36 +0100
+Subject: [PATCH 4/5] Fix use of lex/yacc
+
+http://www.gnu.org/software/automake/manual/html_node/Yacc-and-Lex.html
+---
+ configure.ac | 1 +
+ lib/libsql/Makefile.am | 17 +++++++----------
+ 2 files changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 30ea37a..23865ea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,6 +45,7 @@ AC_PROG_CXX
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_HEADER_STDC
++AM_PROG_LEX
+ AC_PROG_YACC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+diff --git a/lib/libsql/Makefile.am b/lib/libsql/Makefile.am
+index c9534fb..78f26cc 100644
+--- a/lib/libsql/Makefile.am
++++ b/lib/libsql/Makefile.am
+@@ -5,9 +5,8 @@ lib_LTLIBRARIES = libqofsql.la
+ libqofsql_la_LDFLAGS= -version-info $(LIBQOFSQL_LIBRARY_VERSION)
+
+ libqofsql_la_SOURCES = \
+- parser.c \
+- parser.h \
+- lexer.c \
++ parser.y \
++ lexer.l \
+ sql_parser.c \
+ sql_parser.h \
+ mem.c \
+@@ -24,9 +23,7 @@ qofsqlinclude_HEADERS = sql_parser.h
+ check_PROGRAMS = sql_parse_test
+
+ EXTRA_DIST = \
+- README \
+- lexer.l \
+- parser.y
++ README
+
+ AM_CFLAGS = -g \
+ ${CFLAGS} \
+@@ -35,11 +32,11 @@ AM_CFLAGS = -g \
+ #INCLUDES = \
+ # -I$(includedir)
+
+-parser.c: parser.y
+- $(YACC) -v -d -o parser.c -p sql parser.y
++AM_YFLAGS = -v -d -p sql
++AM_LFLAGS = -Psql -o$@
+
+-lexer.c: lexer.l parser.c
+- $(LEX) -olexer.c -Psql lexer.l
++BUILT_SOURCES = parser.h
++CLEANFILES = $(BUILT_SOURCES)
+
+ sql_parse_test_SOURCES=sql_parse_test.c
+ # sql_parse_test_LDFLAGS = $(LIBGDA_LIBS)
+--
+2.1.2
+