summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/protobuf/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/protobuf/files')
-rw-r--r--dev-libs/protobuf/files/protobuf-3.5.0-atomic_operations.patch21
-rw-r--r--dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch (renamed from dev-libs/protobuf/files/protobuf-3.4.0-disable_no-warning-test.patch)10
-rw-r--r--dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch (renamed from dev-libs/protobuf/files/protobuf-3.4.0-protoc_input_output_files.patch)83
-rw-r--r--dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch (renamed from dev-libs/protobuf/files/protobuf-3.4.0-system_libraries.patch)94
-rw-r--r--dev-libs/protobuf/files/protobuf-3.8.0-protoc_input_output_files.patch262
5 files changed, 359 insertions, 111 deletions
diff --git a/dev-libs/protobuf/files/protobuf-3.5.0-atomic_operations.patch b/dev-libs/protobuf/files/protobuf-3.5.0-atomic_operations.patch
deleted file mode 100644
index 9582431d41f6..000000000000
--- a/dev-libs/protobuf/files/protobuf-3.5.0-atomic_operations.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://github.com/protocolbuffers/protobuf/issues/3937
-https://github.com/protocolbuffers/protobuf/pull/3955
-https://github.com/protocolbuffers/protobuf/commit/642e1ac635f2563b4a14c255374f02645ae85dac
-
---- /src/google/protobuf/stubs/atomicops_internals_generic_gcc.h
-+++ /src/google/protobuf/stubs/atomicops_internals_generic_gcc.h
-@@ -146,6 +146,14 @@
- return __atomic_load_n(ptr, __ATOMIC_RELAXED);
- }
-
-+inline Atomic64 Release_CompareAndSwap(volatile Atomic64* ptr,
-+ Atomic64 old_value,
-+ Atomic64 new_value) {
-+ __atomic_compare_exchange_n(ptr, &old_value, new_value, false,
-+ __ATOMIC_RELEASE, __ATOMIC_ACQUIRE);
-+ return old_value;
-+}
-+
- #endif // defined(__LP64__)
-
- } // namespace internal
diff --git a/dev-libs/protobuf/files/protobuf-3.4.0-disable_no-warning-test.patch b/dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch
index 373dc7935a89..eadde9c04dc7 100644
--- a/dev-libs/protobuf/files/protobuf-3.4.0-disable_no-warning-test.patch
+++ b/dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch
@@ -2,16 +2,16 @@ Disable no-warning-test which is compiled with -Werror option and whose only pur
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -750,7 +750,7 @@
-
+@@ -709,7 +709,7 @@
+ GOOGLEMOCK_SRC_DIR=$(srcdir)/../third_party/googletest/googlemock
check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
protobuf-lite-test test_plugin protobuf-lite-arena-test \
- no-warning-test $(GZCHECKPROGRAMS)
+ $(GZCHECKPROGRAMS)
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
- ../gmock/gtest/lib/libgtest.la \
- ../gmock/lib/libgmock.la \
-@@ -931,4 +931,4 @@
+ $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
+ $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
+@@ -893,4 +893,4 @@
TESTS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test \
google/protobuf/compiler/zip_output_unittest.sh $(GZTESTS) \
diff --git a/dev-libs/protobuf/files/protobuf-3.4.0-protoc_input_output_files.patch b/dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch
index 75c4dc28ee4a..54daa6de4ed2 100644
--- a/dev-libs/protobuf/files/protobuf-3.4.0-protoc_input_output_files.patch
+++ b/dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch
@@ -2,7 +2,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
--- /src/google/protobuf/compiler/command_line_interface.cc
+++ /src/google/protobuf/compiler/command_line_interface.cc
-@@ -942,6 +942,28 @@
+@@ -951,6 +951,28 @@
}
if (mode_ == MODE_ENCODE || mode_ == MODE_DECODE) {
@@ -31,7 +31,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
if (codec_type_.empty()) {
// HACK: Define an EmptyMessage type to use for decoding.
DescriptorPool pool;
-@@ -950,13 +972,20 @@
+@@ -959,13 +981,20 @@
file.add_message_type()->set_name("EmptyMessage");
GOOGLE_CHECK(pool.BuildFile(file) != NULL);
codec_type_ = "EmptyMessage";
@@ -58,7 +58,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
}
}
-@@ -994,6 +1023,11 @@
+@@ -1003,6 +1032,11 @@
for (int i = 0; i < proto_path_.size(); i++) {
source_tree->MapPath(proto_path_[i].first, proto_path_[i].second);
}
@@ -69,8 +69,8 @@ https://github.com/protocolbuffers/protobuf/pull/235
+ }
// Map input files to virtual paths if possible.
- if (!MakeInputsBeProtoPathRelative(source_tree)) {
-@@ -1561,6 +1595,12 @@
+ if (!MakeInputsBeProtoPathRelative(source_tree, fallback_database)) {
+@@ -1622,6 +1656,12 @@
codec_type_ = value;
@@ -83,7 +83,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
} else if (name == "--error_format") {
if (value == "gcc") {
error_format_ = ERROR_FORMAT_GCC;
-@@ -1684,18 +1724,29 @@
+@@ -1749,18 +1789,31 @@
" --version Show version info and exit.\n"
" -h, --help Show this text and exit.\n"
" --encode=MESSAGE_TYPE Read a text-format message of the given type\n"
@@ -93,7 +93,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
-" --decode=MESSAGE_TYPE Read a binary message of the given type from\n"
-" standard input and write it in text format\n"
-" to standard output. The message type must\n"
-+" an write it in binary. The message type must\n"
++" and write it in binary. The message type must\n"
" be defined in PROTO_FILES or their imports.\n"
-" --decode_raw Read an arbitrary protocol message from\n"
-" standard input and write the raw tag/value\n"
@@ -103,27 +103,29 @@ https://github.com/protocolbuffers/protobuf/pull/235
+" command line flags.\n"
+" --decode=MESSAGE_TYPE Read a binary message of the given type and\n"
+" write it in text format. The message type\n"
-+" must be defined in PROTO_FILES or their\n"
-+" imports. The input/output protobuf files are\n"
-+" specified using the --protobuf_in and \n"
-+" --protobuf_out command line flags.\n"
++" must be defined in PROTO_FILES or their imports.\n"
++" The input/output protobuf files are specified\n"
++" using the --protobuf_in and --protobuf_out\n"
++" command line flags.\n"
+" --decode_raw Read an arbitrary protocol message and write\n"
+" the raw tag/value pairs in text format. No\n"
" PROTO_FILES should be given when using this\n"
-" flag.\n"
-+" flag. The input/output protobuf files are\n"
-+" specified using the --protobuf_in and \n"
++" flag. The input/output protobuf files are\n"
++" specified using the --protobuf_in and\n"
+" --protobuf_out command line flags.\n"
-+" --protobuf_in Absolute path to the protobuf file to read to\n"
-+" encode/decode. If omitted, file will be read\n"
-+" from STDIN.\n"
-+" --protobuf_out Absolute path to the protobuf file to write to\n"
-+" after encode/decode operation. If omitted,\n"
-+" output is written to STDOUT.\n"
++" --protobuf_in=FILE Absolute path to the protobuf file from which\n"
++" input of encoding/decoding operation will be\n"
++" read. If omitted, input will be read from\n"
++" standard input.\n"
++" --protobuf_out=FILE Absolute path to the protobuf file to which\n"
++" output of encoding/decoding operation will be\n"
++" written. If omitted, output will be written to\n"
++" standard output.\n"
" --descriptor_set_in=FILES Specifies a delimited list of FILES\n"
" each containing a FileDescriptorSet (a\n"
" protocol buffer defined in descriptor.proto).\n"
-@@ -1957,7 +2008,9 @@
+@@ -2039,7 +2092,9 @@
return true;
}
@@ -134,8 +136,8 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Look up the type.
const Descriptor* type = pool->FindMessageTypeByName(codec_type_);
if (type == NULL) {
-@@ -1969,15 +2022,15 @@
- google::protobuf::scoped_ptr<Message> message(dynamic_factory.GetPrototype(type)->New());
+@@ -2051,15 +2106,15 @@
+ std::unique_ptr<Message> message(dynamic_factory.GetPrototype(type)->New());
if (mode_ == MODE_ENCODE) {
- SetFdToTextMode(STDIN_FILENO);
@@ -158,8 +160,8 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Input is text.
--- /src/google/protobuf/compiler/command_line_interface.h
+++ /src/google/protobuf/compiler/command_line_interface.h
-@@ -269,7 +269,9 @@
- GeneratorContext* generator_context, string* error);
+@@ -285,7 +285,9 @@
+ GeneratorContext* generator_context, std::string* error);
// Implements --encode and --decode.
- bool EncodeOrDecode(const DescriptorPool* pool);
@@ -169,20 +171,20 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Implements the --descriptor_set_out option.
bool WriteDescriptorSet(
-@@ -402,6 +404,13 @@
+@@ -418,6 +420,13 @@
// parsed FileDescriptorSets to be used for loading protos. Otherwise, empty.
- std::vector<string> descriptor_set_in_names_;
+ std::vector<std::string> descriptor_set_in_names_;
+ // When using --encode / --decode / --decode_raw absolute path to the output
+ // file. (Empty string indicates write to STDOUT).
-+ string protobuf_out_path_;
++ std::string protobuf_out_path_;
+ // When using --encode / --decode / --decode_raw, absolute path to the input
+ // file. (Empty string indicates read from STDIN).
-+ string protobuf_in_path_;
++ std::string protobuf_in_path_;
+
// If --descriptor_set_out was given, this is the filename to which the
// FileDescriptorSet should be written. Otherwise, empty.
- string descriptor_set_out_name_;
+ std::string descriptor_set_out_name_;
--- /src/google/protobuf/compiler/command_line_interface_unittest.cc
+++ /src/google/protobuf/compiler/command_line_interface_unittest.cc
@@ -95,7 +95,7 @@
@@ -194,7 +196,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// command is automatically split on spaces, and the string "$tmpdir"
// is replaced with TestTempDir().
void Run(const string& command);
-@@ -2308,6 +2308,17 @@
+@@ -2367,6 +2367,17 @@
EXPECT_EQ(StripCR(expected_text), StripCR(captured_stderr_));
}
@@ -212,20 +214,21 @@ https://github.com/protocolbuffers/protobuf/pull/235
private:
void WriteUnittestProtoDescriptorSet() {
unittest_proto_descriptor_set_filename_ =
-@@ -2398,6 +2409,18 @@
- "google/protobuf/no_such_file.proto: No such file or directory\n");
+@@ -2463,6 +2474,19 @@
+ "net/proto2/internal/no_such_file.proto: No such file or directory\n");
}
+TEST_P(EncodeDecodeTest, RedirectInputOutput) {
+ string out_file = TestTempDir() + "/golden_message_out.pbf";
-+ string cmd = "";
-+ cmd += "google/protobuf/unittest.proto ";
-+ cmd += "--encode=protobuf_unittest.TestAllTypes ";
-+ cmd += "--protobuf_in=" + TestSourceDir() +
-+ "/google/protobuf/testdata/text_format_unittest_data_oneof_implemented.txt ";
-+ cmd += "--protobuf_out=" + out_file;
-+ EXPECT_TRUE(Run(cmd));
-+ ExpectBinaryFilesMatch(out_file, TestSourceDir() + "/google/protobuf/testdata/golden_message_oneof_implemented");
++ EXPECT_TRUE(
++ Run(TestUtil::MaybeTranslatePath("net/proto2/internal/unittest.proto") +
++ " --encode=protobuf_unittest.TestAllTypes" +
++ " --protobuf_in=" + TestUtil::GetTestDataPath(
++ "net/proto2/internal/"
++ "testdata/text_format_unittest_data_oneof_implemented.txt") +
++ " --protobuf_out=" + out_file));
++ ExpectBinaryFilesMatch(out_file, TestUtil::GetTestDataPath(
++ "net/proto2/internal/testdata/golden_message_oneof_implemented"));
+}
+
INSTANTIATE_TEST_CASE_P(FileDescriptorSetSource,
diff --git a/dev-libs/protobuf/files/protobuf-3.4.0-system_libraries.patch b/dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch
index 424ad5ff58c3..3ae92e2b87a5 100644
--- a/dev-libs/protobuf/files/protobuf-3.4.0-system_libraries.patch
+++ b/dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch
@@ -1,12 +1,8 @@
--- /Makefile.am
+++ /Makefile.am
-@@ -8,31 +8,12 @@
- # the right time.
- SUBDIRS = . src
-
--# Always include gmock in distributions.
--DIST_SUBDIRS = $(subdirs) src conformance benchmarks
-+DIST_SUBDIRS = src conformance benchmarks
+@@ -11,28 +11,10 @@
+ # Always include third_party directories in distributions.
+ DIST_SUBDIRS = src conformance benchmarks third_party/googletest
-# Build gmock before we build protobuf tests. We don't add gmock to SUBDIRS
-# because then "make check" would also build and run all of gmock's own tests,
@@ -15,8 +11,8 @@
-# the installed version of gmock if there is one.
check-local:
- @echo "Making lib/libgmock.a lib/libgmock_main.a in gmock"
-- @cd gmock && $(MAKE) $(AM_MAKEFLAGS) lib/libgmock.la lib/libgmock_main.la
-- @cd gmock/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+- @cd third_party/googletest/googletest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+- @cd third_party/googletest/googlemock && $(MAKE) $(AM_MAKEFLAGS) lib/libgmock.la lib/libgmock_main.la
-# We would like to clean gmock when "make clean" is invoked. But we have to
-# be careful because clean-local is also invoked during "make distclean", but
@@ -25,9 +21,9 @@
-# cd to the directory again and "make clean" it will fail. So, check that the
-# Makefile exists before recursing.
clean-local:
-- @if test -e gmock/Makefile; then \
-- echo "Making clean in gmock"; \
-- cd gmock && $(MAKE) $(AM_MAKEFLAGS) clean; \
+- @if test -e third_party/googletest/Makefile; then \
+- echo "Making clean in googletest"; \
+- cd third_party/googletest && $(MAKE) $(AM_MAKEFLAGS) clean; \
- fi; \
- if test -e conformance/Makefile; then \
+ @if test -e conformance/Makefile; then \
@@ -36,81 +32,89 @@
fi; \
--- /configure.ac
+++ /configure.ac
-@@ -200,12 +200,5 @@
-
- AX_CXX_COMPILE_STDCXX([11], [noext], [optional])
+@@ -218,12 +218,5 @@
+ esac
+ AM_CONDITIONAL([OBJC_CONFORMANCE_TEST], [test $OBJC_CONFORMANCE_TEST = 1])
-# HACK: Make gmock's configure script pick up our copy of CFLAGS and CXXFLAGS,
-# since the flags added by ACX_CHECK_SUNCC must be used when compiling gmock
-# too.
-export CFLAGS
-export CXXFLAGS
--AC_CONFIG_SUBDIRS([gmock])
+-AC_CONFIG_SUBDIRS([third_party/googletest])
-
AC_CONFIG_FILES([Makefile src/Makefile benchmarks/Makefile conformance/Makefile protobuf.pc protobuf-lite.pc])
AC_OUTPUT
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -752,11 +752,7 @@
+@@ -703,19 +703,11 @@
+ google/protobuf/testing/file.cc \
+ google/protobuf/testing/file.h
+
+-GOOGLETEST_BUILD_DIR=../third_party/googletest/googletest
+-GOOGLEMOCK_BUILD_DIR=../third_party/googletest/googlemock
+-GOOGLETEST_SRC_DIR=$(srcdir)/../third_party/googletest/googletest
+-GOOGLEMOCK_SRC_DIR=$(srcdir)/../third_party/googletest/googlemock
+ check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
protobuf-lite-test test_plugin protobuf-lite-arena-test \
- no-warning-test $(GZCHECKPROGRAMS)
+ $(GZCHECKPROGRAMS)
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
-- ../gmock/gtest/lib/libgtest.la \
-- ../gmock/lib/libgmock.la \
-- ../gmock/lib/libgmock_main.la
--protobuf_test_CPPFLAGS = -I$(srcdir)/../gmock/gtest/include \
-- -I$(srcdir)/../gmock/include
+- $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock_main.la
+-protobuf_test_CPPFLAGS = -I$(GOOGLETEST_SRC_DIR)/include \
+- -I$(GOOGLEMOCK_SRC_DIR)/include
+ -lgtest -lgmock -lgmock_main
# Disable optimization for tests unless the user explicitly asked for it,
# since test_util.cc takes forever to compile with optimization (with GCC).
# See configure.ac for more info.
-@@ -843,12 +839,8 @@
+@@ -804,12 +796,8 @@
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
libprotoc.la \
-- ../gmock/gtest/lib/libgtest.la \
-- ../gmock/lib/libgmock.la \
-- ../gmock/lib/libgmock_main.la
--protobuf_lazy_descriptor_test_CPPFLAGS = -I$(srcdir)/../gmock/include \
-- -I$(srcdir)/../gmock/gtest/include \
+- $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock_main.la
+-protobuf_lazy_descriptor_test_CPPFLAGS = -I$(GOOGLEMOCK_SRC_DIR)/include \
+- -I$(GOOGLETEST_SRC_DIR)/include \
- -DPROTOBUF_TEST_NO_DESCRIPTORS
+ -lgtest -lgmock -lgmock_main
+protobuf_lazy_descriptor_test_CPPFLAGS = -DPROTOBUF_TEST_NO_DESCRIPTORS
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lazy_descriptor_test_SOURCES = \
google/protobuf/compiler/cpp/cpp_unittest.cc \
-@@ -868,11 +860,7 @@
+@@ -830,11 +818,7 @@
# full runtime and we want to make sure this test builds without full
# runtime.
- protobuf_lite_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
-- ../gmock/gtest/lib/libgtest.la \
-- ../gmock/lib/libgmock.la \
-- ../gmock/lib/libgmock_main.la
--protobuf_lite_test_CPPFLAGS= -I$(srcdir)/../gmock/include \
-- -I$(srcdir)/../gmock/gtest/include
+ protobuf_lite_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
+- $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock_main.la
+-protobuf_lite_test_CPPFLAGS= -I$(GOOGLEMOCK_SRC_DIR)/include \
+- -I$(GOOGLETEST_SRC_DIR)/include
+ -lgtest -lgmock -lgmock_main
protobuf_lite_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_test_SOURCES = \
google/protobuf/lite_unittest.cc \
-@@ -883,11 +871,7 @@
+@@ -846,11 +830,7 @@
# gtest when building the test internally our memory sanitizer doesn't detect
# memory leaks (don't know why).
protobuf_lite_arena_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
-- ../gmock/gtest/lib/libgtest.la \
-- ../gmock/lib/libgmock.la \
-- ../gmock/lib/libgmock_main.la
--protobuf_lite_arena_test_CPPFLAGS = -I$(srcdir)/../gmock/include \
-- -I$(srcdir)/../gmock/gtest/include
+- $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
+- $(GOOGLEMOCK_BUILD_DIR)/lib/libgmock_main.la
+-protobuf_lite_arena_test_CPPFLAGS = -I$(GOOGLEMOCK_SRC_DIR)/include \
+- -I$(GOOGLETEST_SRC_DIR)/include
+ -lgtest -lgmock -lgmock_main
protobuf_lite_arena_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_arena_test_SOURCES = \
google/protobuf/lite_arena_unittest.cc \
-@@ -896,8 +880,7 @@
+@@ -860,8 +840,7 @@
# Test plugin binary.
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
-- ../gmock/gtest/lib/libgtest.la
--test_plugin_CPPFLAGS = -I$(srcdir)/../gmock/gtest/include
+- $(GOOGLETEST_BUILD_DIR)/lib/libgtest.la
+-test_plugin_CPPFLAGS = -I$(GOOGLETEST_SRC_DIR)/include
+ -lgtest
test_plugin_SOURCES = \
google/protobuf/compiler/mock_code_generator.cc \
diff --git a/dev-libs/protobuf/files/protobuf-3.8.0-protoc_input_output_files.patch b/dev-libs/protobuf/files/protobuf-3.8.0-protoc_input_output_files.patch
new file mode 100644
index 000000000000..a60bd74f39a1
--- /dev/null
+++ b/dev-libs/protobuf/files/protobuf-3.8.0-protoc_input_output_files.patch
@@ -0,0 +1,262 @@
+https://github.com/protocolbuffers/protobuf/pull/235
+
+--- /src/google/protobuf/compiler/command_line_interface.cc
++++ /src/google/protobuf/compiler/command_line_interface.cc
+@@ -949,6 +949,28 @@
+ }
+
+ if (mode_ == MODE_ENCODE || mode_ == MODE_DECODE) {
++ bool success = false;
++ int in_fd = STDIN_FILENO;
++ int out_fd = STDOUT_FILENO;
++
++ if (!protobuf_in_path_.empty()) {
++ in_fd = open(protobuf_in_path_.c_str(), O_RDONLY);
++ if (in_fd == -1) {
++ std::cerr << protobuf_in_path_ << ": error: failed to open file." << std::endl;
++ return 1;
++ }
++ }
++ if (!protobuf_out_path_.empty()) {
++ out_fd = open(protobuf_out_path_.c_str(),
++ O_WRONLY | O_CREAT | O_TRUNC,
++ 0644);
++ if (out_fd == -1) {
++ std::cerr << protobuf_out_path_ << ": error: failed to open file." << std::endl;
++ close(in_fd);
++ return 1;
++ }
++ }
++
+ if (codec_type_.empty()) {
+ // HACK: Define an EmptyMessage type to use for decoding.
+ DescriptorPool pool;
+@@ -957,13 +979,20 @@
+ file.add_message_type()->set_name("EmptyMessage");
+ GOOGLE_CHECK(pool.BuildFile(file) != NULL);
+ codec_type_ = "EmptyMessage";
+- if (!EncodeOrDecode(&pool)) {
+- return 1;
+- }
++ success = EncodeOrDecode(&pool, in_fd, out_fd);
+ } else {
+- if (!EncodeOrDecode(descriptor_pool.get())) {
+- return 1;
+- }
++ success = EncodeOrDecode(descriptor_pool.get(), in_fd, out_fd);
++ }
++
++ if (in_fd != STDIN_FILENO) {
++ close(in_fd);
++ }
++ if (out_fd != STDOUT_FILENO) {
++ close(out_fd);
++ }
++
++ if (!success) {
++ return 1;
+ }
+ }
+
+@@ -1001,6 +1030,11 @@
+ for (int i = 0; i < proto_path_.size(); i++) {
+ source_tree->MapPath(proto_path_[i].first, proto_path_[i].second);
+ }
++ if (mode_ == MODE_COMPILE &&
++ (!protobuf_in_path_.empty() || !protobuf_out_path_.empty())) {
++ std::cerr << "--protobuf_in and --protobuf_out are only valid with "
++ << "decode operations. Ignoring.";
++ }
+
+ // Map input files to virtual paths if possible.
+ if (!MakeInputsBeProtoPathRelative(source_tree, fallback_database)) {
+@@ -1627,6 +1661,12 @@
+
+ codec_type_ = value;
+
++ } else if (name == "--protobuf_in") {
++ protobuf_in_path_ = value;
++
++ } else if (name == "--protobuf_out") {
++ protobuf_out_path_ = value;
++
+ } else if (name == "--error_format") {
+ if (value == "gcc") {
+ error_format_ = ERROR_FORMAT_GCC;
+@@ -1763,29 +1803,50 @@
+ " -h, --help Show this text and exit.\n"
+ " --encode=MESSAGE_TYPE Read a text-format message of the "
+ "given type\n"
+- " from standard input and write it in "
+- "binary\n"
+- " to standard output. The message type "
+- "must\n"
++ " and write it in binary. The message "
++ "type must\n"
+ " be defined in PROTO_FILES or their "
+ "imports.\n"
++ " The input/output protobuf files are "
++ "specified\n"
++ " using the --protobuf_in and "
++ "--protobuf_out\n"
++ " command line flags.\n"
+ " --decode=MESSAGE_TYPE Read a binary message of the given "
+- "type from\n"
+- " standard input and write it in text "
+- "format\n"
+- " to standard output. The message type "
+- "must\n"
+- " be defined in PROTO_FILES or their "
+- "imports.\n"
++ "type and\n"
++ " write it in text format. The message "
++ "type\n"
++ " must be defined in PROTO_FILES or "
++ "their imports.\n"
++ " The input/output protobuf files are "
++ "specified\n"
++ " using the --protobuf_in and "
++ "--protobuf_out\n"
++ " command line flags.\n"
+ " --decode_raw Read an arbitrary protocol message "
+- "from\n"
+- " standard input and write the raw "
+- "tag/value\n"
+- " pairs in text format to standard "
+- "output. No\n"
++ "and write\n"
++ " the raw tag/value pairs in text format."
++ " No\n"
+ " PROTO_FILES should be given when using "
+ "this\n"
+- " flag.\n"
++ " flag. The input/output protobuf files "
++ "are\n"
++ " specified using the --protobuf_in and\n"
++ " --protobuf_out command line flags.\n"
++ " --protobuf_in=FILE Absolute path to the protobuf file "
++ "from which\n"
++ " input of encoding/decoding operation "
++ "will be\n"
++ " read. If omitted, input will be read "
++ "from\n"
++ " standard input.\n"
++ " --protobuf_out=FILE Absolute path to the protobuf file "
++ "to which\n"
++ " output of encoding/decoding operation "
++ "will be\n"
++ " written. If omitted, output will be "
++ "written to\n"
++ " standard output.\n"
+ " --descriptor_set_in=FILES Specifies a delimited list of FILES\n"
+ " each containing a FileDescriptorSet "
+ "(a\n"
+@@ -2101,7 +2162,9 @@
+ return true;
+ }
+
+-bool CommandLineInterface::EncodeOrDecode(const DescriptorPool* pool) {
++bool CommandLineInterface::EncodeOrDecode(const DescriptorPool* pool,
++ int in_fd,
++ int out_fd) {
+ // Look up the type.
+ const Descriptor* type = pool->FindMessageTypeByName(codec_type_);
+ if (type == NULL) {
+@@ -2113,15 +2176,15 @@
+ std::unique_ptr<Message> message(dynamic_factory.GetPrototype(type)->New());
+
+ if (mode_ == MODE_ENCODE) {
+- SetFdToTextMode(STDIN_FILENO);
+- SetFdToBinaryMode(STDOUT_FILENO);
++ SetFdToTextMode(in_fd);
++ SetFdToBinaryMode(out_fd);
+ } else {
+- SetFdToBinaryMode(STDIN_FILENO);
+- SetFdToTextMode(STDOUT_FILENO);
++ SetFdToBinaryMode(in_fd);
++ SetFdToTextMode(out_fd);
+ }
+
+- io::FileInputStream in(STDIN_FILENO);
+- io::FileOutputStream out(STDOUT_FILENO);
++ io::FileInputStream in(in_fd);
++ io::FileOutputStream out(out_fd);
+
+ if (mode_ == MODE_ENCODE) {
+ // Input is text.
+--- /src/google/protobuf/compiler/command_line_interface.h
++++ /src/google/protobuf/compiler/command_line_interface.h
+@@ -286,7 +286,9 @@
+ GeneratorContext* generator_context, std::string* error);
+
+ // Implements --encode and --decode.
+- bool EncodeOrDecode(const DescriptorPool* pool);
++ bool EncodeOrDecode(const DescriptorPool* pool,
++ int in_fd,
++ int out_fd);
+
+ // Implements the --descriptor_set_out option.
+ bool WriteDescriptorSet(
+@@ -418,6 +420,13 @@
+ // parsed FileDescriptorSets to be used for loading protos. Otherwise, empty.
+ std::vector<std::string> descriptor_set_in_names_;
+
++ // When using --encode / --decode / --decode_raw absolute path to the output
++ // file. (Empty string indicates write to STDOUT).
++ std::string protobuf_out_path_;
++ // When using --encode / --decode / --decode_raw, absolute path to the input
++ // file. (Empty string indicates read from STDIN).
++ std::string protobuf_in_path_;
++
+ // If --descriptor_set_out was given, this is the filename to which the
+ // FileDescriptorSet should be written. Otherwise, empty.
+ std::string descriptor_set_out_name_;
+--- /src/google/protobuf/compiler/command_line_interface_unittest.cc
++++ /src/google/protobuf/compiler/command_line_interface_unittest.cc
+@@ -95,7 +95,7 @@
+ virtual void SetUp();
+ virtual void TearDown();
+
+- // Runs the CommandLineInterface with the given command line. The
++ // Run the CommandLineInterface with the given command line. The
+ // command is automatically split on spaces, and the string "$tmpdir"
+ // is replaced with TestTempDir().
+ void Run(const std::string& command);
+@@ -2337,6 +2337,17 @@
+ EXPECT_EQ(StripCR(expected_text), StripCR(captured_stderr_));
+ }
+
++ void ExpectBinaryFilesMatch(const string &expected_file,
++ const string &actual_file) {
++ string expected_output, actual_output;
++ ASSERT_TRUE(File::ReadFileToString(expected_file, &expected_output));
++ ASSERT_TRUE(File::ReadFileToString(actual_file, &actual_output));
++
++ // Don't use EXPECT_EQ because we don't want to print raw binary data to
++ // stdout on failure.
++ EXPECT_TRUE(expected_output == actual_output);
++ }
++
+ private:
+ void WriteUnittestProtoDescriptorSet() {
+ unittest_proto_descriptor_set_filename_ =
+@@ -2431,6 +2442,19 @@
+ "net/proto2/internal/no_such_file.proto: No such file or directory\n");
+ }
+
++TEST_P(EncodeDecodeTest, RedirectInputOutput) {
++ string out_file = TestTempDir() + "/golden_message_out.pbf";
++ EXPECT_TRUE(
++ Run(TestUtil::MaybeTranslatePath("net/proto2/internal/unittest.proto") +
++ " --encode=protobuf_unittest.TestAllTypes" +
++ " --protobuf_in=" + TestUtil::GetTestDataPath(
++ "net/proto2/internal/"
++ "testdata/text_format_unittest_data_oneof_implemented.txt") +
++ " --protobuf_out=" + out_file));
++ ExpectBinaryFilesMatch(out_file, TestUtil::GetTestDataPath(
++ "net/proto2/internal/testdata/golden_message_oneof_implemented"));
++}
++
+ INSTANTIATE_TEST_SUITE_P(FileDescriptorSetSource, EncodeDecodeTest,
+ testing::Values(PROTO_PATH, DESCRIPTOR_SET_IN));
+ } // anonymous namespace