summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/protobuf/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/protobuf/files')
-rw-r--r--dev-libs/protobuf/files/protobuf-3.11.0-disable_no-warning-test.patch (renamed from dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch)4
-rw-r--r--dev-libs/protobuf/files/protobuf-3.11.0-protoc_input_output_files.patch (renamed from dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch)140
-rw-r--r--dev-libs/protobuf/files/protobuf-3.11.0-system_libraries.patch (renamed from dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch)12
3 files changed, 91 insertions, 65 deletions
diff --git a/dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch b/dev-libs/protobuf/files/protobuf-3.11.0-disable_no-warning-test.patch
index eadde9c04dc7..ec043e3865c1 100644
--- a/dev-libs/protobuf/files/protobuf-3.7.0-disable_no-warning-test.patch
+++ b/dev-libs/protobuf/files/protobuf-3.11.0-disable_no-warning-test.patch
@@ -2,7 +2,7 @@ Disable no-warning-test which is compiled with -Werror option and whose only pur
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -709,7 +709,7 @@
+@@ -714,7 +714,7 @@
GOOGLEMOCK_SRC_DIR=$(srcdir)/../third_party/googletest/googlemock
check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
protobuf-lite-test test_plugin protobuf-lite-arena-test \
@@ -11,7 +11,7 @@ Disable no-warning-test which is compiled with -Werror option and whose only pur
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
$(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
$(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
-@@ -893,4 +893,4 @@
+@@ -901,4 +901,4 @@
TESTS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test \
google/protobuf/compiler/zip_output_unittest.sh $(GZTESTS) \
diff --git a/dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch b/dev-libs/protobuf/files/protobuf-3.11.0-protoc_input_output_files.patch
index 54daa6de4ed2..0e22b34efc3e 100644
--- a/dev-libs/protobuf/files/protobuf-3.7.0-protoc_input_output_files.patch
+++ b/dev-libs/protobuf/files/protobuf-3.11.0-protoc_input_output_files.patch
@@ -2,7 +2,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
--- /src/google/protobuf/compiler/command_line_interface.cc
+++ /src/google/protobuf/compiler/command_line_interface.cc
-@@ -951,6 +951,28 @@
+@@ -938,6 +938,28 @@
}
if (mode_ == MODE_ENCODE || mode_ == MODE_DECODE) {
@@ -31,7 +31,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
if (codec_type_.empty()) {
// HACK: Define an EmptyMessage type to use for decoding.
DescriptorPool pool;
-@@ -959,13 +981,20 @@
+@@ -946,13 +968,20 @@
file.add_message_type()->set_name("EmptyMessage");
GOOGLE_CHECK(pool.BuildFile(file) != NULL);
codec_type_ = "EmptyMessage";
@@ -58,7 +58,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
}
}
-@@ -1003,6 +1032,11 @@
+@@ -990,6 +1019,11 @@
for (int i = 0; i < proto_path_.size(); i++) {
source_tree->MapPath(proto_path_[i].first, proto_path_[i].second);
}
@@ -70,7 +70,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Map input files to virtual paths if possible.
if (!MakeInputsBeProtoPathRelative(source_tree, fallback_database)) {
-@@ -1622,6 +1656,12 @@
+@@ -1650,6 +1684,12 @@
codec_type_ = value;
@@ -83,49 +83,75 @@ https://github.com/protocolbuffers/protobuf/pull/235
} else if (name == "--error_format") {
if (value == "gcc") {
error_format_ = ERROR_FORMAT_GCC;
-@@ -1749,18 +1789,31 @@
- " --version Show version info and exit.\n"
- " -h, --help Show this text and exit.\n"
- " --encode=MESSAGE_TYPE Read a text-format message of the given type\n"
--" from standard input and write it in binary\n"
--" to standard output. The message type must\n"
--" be defined in PROTO_FILES or their imports.\n"
--" --decode=MESSAGE_TYPE Read a binary message of the given type from\n"
--" standard input and write it in text format\n"
--" to standard output. The message type must\n"
-+" and write it in binary. The message type must\n"
- " be defined in PROTO_FILES or their imports.\n"
--" --decode_raw Read an arbitrary protocol message from\n"
--" standard input and write the raw tag/value\n"
--" pairs in text format to standard output. No\n"
-+" The input/output protobuf files are specified\n"
-+" using the --protobuf_in and --protobuf_out\n"
-+" command line flags.\n"
-+" --decode=MESSAGE_TYPE Read a binary message of the given type and\n"
-+" write it in text format. The message type\n"
-+" must be defined in PROTO_FILES or their imports.\n"
-+" The input/output protobuf files are specified\n"
-+" using the --protobuf_in and --protobuf_out\n"
-+" command line flags.\n"
-+" --decode_raw Read an arbitrary protocol message and write\n"
-+" the raw tag/value pairs in text format. No\n"
- " PROTO_FILES should be given when using this\n"
--" flag.\n"
-+" flag. The input/output protobuf files are\n"
-+" specified using the --protobuf_in and\n"
-+" --protobuf_out command line flags.\n"
-+" --protobuf_in=FILE Absolute path to the protobuf file from which\n"
-+" input of encoding/decoding operation will be\n"
-+" read. If omitted, input will be read from\n"
-+" standard input.\n"
-+" --protobuf_out=FILE Absolute path to the protobuf file to which\n"
-+" output of encoding/decoding operation will be\n"
-+" written. If omitted, output will be written to\n"
-+" standard output.\n"
- " --descriptor_set_in=FILES Specifies a delimited list of FILES\n"
- " each containing a FileDescriptorSet (a\n"
- " protocol buffer defined in descriptor.proto).\n"
-@@ -2039,7 +2092,9 @@
+@@ -1786,29 +1826,50 @@
+ " -h, --help Show this text and exit.\n"
+ " --encode=MESSAGE_TYPE Read a text-format message of the "
+ "given type\n"
+- " from standard input and write it in "
+- "binary\n"
+- " to standard output. The message type "
+- "must\n"
++ " and write it in binary. The message "
++ "type must\n"
+ " be defined in PROTO_FILES or their "
+ "imports.\n"
++ " The input/output protobuf files are "
++ "specified\n"
++ " using the --protobuf_in and "
++ "--protobuf_out\n"
++ " command line flags.\n"
+ " --decode=MESSAGE_TYPE Read a binary message of the given "
+- "type from\n"
+- " standard input and write it in text "
+- "format\n"
+- " to standard output. The message type "
+- "must\n"
+- " be defined in PROTO_FILES or their "
+- "imports.\n"
++ "type and\n"
++ " write it in text format. The message "
++ "type\n"
++ " must be defined in PROTO_FILES or "
++ "their imports.\n"
++ " The input/output protobuf files are "
++ "specified\n"
++ " using the --protobuf_in and "
++ "--protobuf_out\n"
++ " command line flags.\n"
+ " --decode_raw Read an arbitrary protocol message "
+- "from\n"
+- " standard input and write the raw "
+- "tag/value\n"
+- " pairs in text format to standard "
+- "output. No\n"
++ "and write\n"
++ " the raw tag/value pairs in text format."
++ " No\n"
+ " PROTO_FILES should be given when using "
+ "this\n"
+- " flag.\n"
++ " flag. The input/output protobuf files "
++ "are\n"
++ " specified using the --protobuf_in and\n"
++ " --protobuf_out command line flags.\n"
++ " --protobuf_in=FILE Absolute path to the protobuf file "
++ "from which\n"
++ " input of encoding/decoding operation "
++ "will be\n"
++ " read. If omitted, input will be read "
++ "from\n"
++ " standard input.\n"
++ " --protobuf_out=FILE Absolute path to the protobuf file "
++ "to which\n"
++ " output of encoding/decoding operation "
++ "will be\n"
++ " written. If omitted, output will be "
++ "written to\n"
++ " standard output.\n"
+ " --descriptor_set_in=FILES Specifies a delimited list of FILES\n"
+ " each containing a FileDescriptorSet "
+ "(a\n"
+@@ -2123,7 +2184,9 @@
return true;
}
@@ -136,7 +162,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Look up the type.
const Descriptor* type = pool->FindMessageTypeByName(codec_type_);
if (type == NULL) {
-@@ -2051,15 +2106,15 @@
+@@ -2135,15 +2198,15 @@
std::unique_ptr<Message> message(dynamic_factory.GetPrototype(type)->New());
if (mode_ == MODE_ENCODE) {
@@ -160,7 +186,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Input is text.
--- /src/google/protobuf/compiler/command_line_interface.h
+++ /src/google/protobuf/compiler/command_line_interface.h
-@@ -285,7 +285,9 @@
+@@ -288,7 +288,9 @@
GeneratorContext* generator_context, std::string* error);
// Implements --encode and --decode.
@@ -171,7 +197,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Implements the --descriptor_set_out option.
bool WriteDescriptorSet(
-@@ -418,6 +420,13 @@
+@@ -420,6 +422,13 @@
// parsed FileDescriptorSets to be used for loading protos. Otherwise, empty.
std::vector<std::string> descriptor_set_in_names_;
@@ -195,9 +221,9 @@ https://github.com/protocolbuffers/protobuf/pull/235
+ // Run the CommandLineInterface with the given command line. The
// command is automatically split on spaces, and the string "$tmpdir"
// is replaced with TestTempDir().
- void Run(const string& command);
-@@ -2367,6 +2367,17 @@
- EXPECT_EQ(StripCR(expected_text), StripCR(captured_stderr_));
+ void Run(const std::string& command);
+@@ -2491,6 +2491,17 @@
+ std::string::npos);
}
+ void ExpectBinaryFilesMatch(const string &expected_file,
@@ -214,7 +240,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
private:
void WriteUnittestProtoDescriptorSet() {
unittest_proto_descriptor_set_filename_ =
-@@ -2463,6 +2474,19 @@
+@@ -2585,6 +2596,19 @@
"net/proto2/internal/no_such_file.proto: No such file or directory\n");
}
@@ -231,6 +257,6 @@ https://github.com/protocolbuffers/protobuf/pull/235
+ "net/proto2/internal/testdata/golden_message_oneof_implemented"));
+}
+
- INSTANTIATE_TEST_CASE_P(FileDescriptorSetSource,
- EncodeDecodeTest,
- testing::Values(PROTO_PATH, DESCRIPTOR_SET_IN));
+ INSTANTIATE_TEST_SUITE_P(FileDescriptorSetSource, EncodeDecodeTest,
+ testing::Values(PROTO_PATH, DESCRIPTOR_SET_IN));
+ } // anonymous namespace
diff --git a/dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch b/dev-libs/protobuf/files/protobuf-3.11.0-system_libraries.patch
index 3ae92e2b87a5..8311ce8b22e9 100644
--- a/dev-libs/protobuf/files/protobuf-3.7.1-system_libraries.patch
+++ b/dev-libs/protobuf/files/protobuf-3.11.0-system_libraries.patch
@@ -32,7 +32,7 @@
fi; \
--- /configure.ac
+++ /configure.ac
-@@ -218,12 +218,5 @@
+@@ -223,12 +223,5 @@
esac
AM_CONDITIONAL([OBJC_CONFORMANCE_TEST], [test $OBJC_CONFORMANCE_TEST = 1])
@@ -47,7 +47,7 @@
AC_OUTPUT
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -703,19 +703,11 @@
+@@ -708,19 +708,11 @@
google/protobuf/testing/file.cc \
google/protobuf/testing/file.h
@@ -68,7 +68,7 @@
# Disable optimization for tests unless the user explicitly asked for it,
# since test_util.cc takes forever to compile with optimization (with GCC).
# See configure.ac for more info.
-@@ -804,12 +796,8 @@
+@@ -812,12 +804,8 @@
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
libprotoc.la \
@@ -83,7 +83,7 @@
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lazy_descriptor_test_SOURCES = \
google/protobuf/compiler/cpp/cpp_unittest.cc \
-@@ -830,11 +818,7 @@
+@@ -838,11 +826,7 @@
# full runtime and we want to make sure this test builds without full
# runtime.
protobuf_lite_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -96,7 +96,7 @@
protobuf_lite_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_test_SOURCES = \
google/protobuf/lite_unittest.cc \
-@@ -846,11 +830,7 @@
+@@ -854,11 +838,7 @@
# gtest when building the test internally our memory sanitizer doesn't detect
# memory leaks (don't know why).
protobuf_lite_arena_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -109,7 +109,7 @@
protobuf_lite_arena_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_arena_test_SOURCES = \
google/protobuf/lite_arena_unittest.cc \
-@@ -860,8 +840,7 @@
+@@ -868,8 +848,7 @@
# Test plugin binary.
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \