summaryrefslogtreecommitdiff
path: root/dev-libs/ppl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-16 02:52:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-16 02:52:59 +0000
commitd17fad940dac9897b8b58d2f1d072869942696a5 (patch)
treee77cd567646e69b19c4e8a8b20a6b201c7f6966e /dev-libs/ppl
parent20e7188871e6d724b707132f925b9872536a91a0 (diff)
gentoo auto-resync : 16:12:2023 - 02:52:59
Diffstat (limited to 'dev-libs/ppl')
-rw-r--r--dev-libs/ppl/Manifest2
-rw-r--r--dev-libs/ppl/ppl-1.2-r5.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/ppl/Manifest b/dev-libs/ppl/Manifest
index a45be92b6d49..f629fa28ac58 100644
--- a/dev-libs/ppl/Manifest
+++ b/dev-libs/ppl/Manifest
@@ -3,5 +3,5 @@ AUX disable-mipproblem2.patch 1098 BLAKE2B b15da536e0e46a2edbec44e4c68a97e57b96d
AUX fix-clang-build.patch 1546 BLAKE2B ba0557f5cb36defa21cc5afdfa8d65bda9fe2a3b8d6262609eccf70e29f6442a7b261b22ffc112ff30cfddc0b8f2a80ffd787d2e9f14f8bb1ba35c095110d695 SHA512 d802c597e408ca50fe01e240c868b2fb5cc2ca3ff00cf15ff1de1c1dc5d0cf0b88da25de0d1151f8011e331f85e343348150285bb515c9ffc17806ff4edd082d
DIST ppl-1.2-r3-disable-boeing-tests.patch 21485 BLAKE2B e68bab59710c63726f04a139e84d72b277e85625bc405c594a22c005186a2c3aae3850e17b81d38fa0231dcfd08454d488bbad2474ed810be78ef646d9c92559 SHA512 fc8dc020e493e5726167741d1548c661bac07991a982bf09ff61f593adfd2faf723886cbcb16d741db61e46530c4dddf49b6b61b67fef7d5ac15ca577c7fc46d
DIST ppl-1.2.tar.xz 14136236 BLAKE2B 060b73384dac558dc8b2b0f1027ed0aa270b0adf0992c2ca1a281fa7bcdf959cba3a9e8ee29e978d12c3eee606b819075c5bcab59f4aed24fbf1c5512b5e2c36 SHA512 b509ed85fa6aedd40119bd4c980b17f33072c56c2acd923da3445b6bc80d48051cfa4c04cce96f6974711f5279c24b31cb3869f87b2eb6a2a1b30a058c809350
-EBUILD ppl-1.2-r5.ebuild 1784 BLAKE2B 39b4df609ceb2f1d3a276ba987d142b7034f417f94ac0759a015092af23c73368af69b2da6dc172591b7d20678c0f480ab4bf19da9352a360100cb9a6f38472d SHA512 0078e44237e2f469fd780449a256d8c8ecf2831cd59b4821620305ad4ca1ba7a5b9a23becce45c2981f940bb88b70bb17455b8faea0b17ce775371548f4f1eaf
+EBUILD ppl-1.2-r5.ebuild 1943 BLAKE2B b9344460eb6e6f9ad50db4f81b043c0052a7b64357bc7d21d42dc5af716dcdefa227d4deb754cc89830afa87688ed97d2fff12123ffdaa6ce3cbc2cdd4796dd9 SHA512 856ec40e089a47bae8d19cd2e1adb085aea41e3023fad29e625bf3b44b72965bbef00ab1d30acab265205649ddc9cdaecb7b554c1f24c3ac5de075b424601507
MISC metadata.xml 890 BLAKE2B ff950fbc0699a9817b2b364e5e4d21aa8d60d40608c8e6ef322e25474c4e528573063e8f62a733e8df3312afbbd8648f5d5bd8de6aa09b1a3cae7cd46fe81a05 SHA512 32ac8e0aca7d550a2a485f6c354e0a71409a3a8c80202609b864e7ceda023d86560787e9c6d38d67276816fadb1126dbf57ff67a0acc247b2833cee85af8c79d
diff --git a/dev-libs/ppl/ppl-1.2-r5.ebuild b/dev-libs/ppl/ppl-1.2-r5.ebuild
index 2f04e7fb2e50..70d986e738f2 100644
--- a/dev-libs/ppl/ppl-1.2-r5.ebuild
+++ b/dev-libs/ppl/ppl-1.2-r5.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="The Parma Polyhedra Library for numerical analysis of complex systems"
HOMEPAGE="http://bugseng.com/products/ppl"
SRC_URI="http://bugseng.com/products/ppl/download/ftp/releases/${PV}/${P}.tar.xz
- https://dev.gentoo.org/~juippis/distfiles/tmp/ppl-1.2-r3-disable-boeing-tests.patch"
+ https://dev.gentoo.org/~juippis/distfiles/tmp/${P}-r3-disable-boeing-tests.patch"
LICENSE="GPL-3"
SLOT="0/4.14" # SONAMEs
@@ -41,6 +41,10 @@ src_prepare() {
}
src_configure() {
+ # mem_fun_ref and friends were removed in c++17, and some toolchains
+ # are beginning to default to that (bug 919850).
+ append-cxxflags -std=c++14
+
local interfaces=( c )
use cxx && interfaces+=( cxx )
econf \