summaryrefslogtreecommitdiff
path: root/dev-libs/popt/popt-1.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-17 05:16:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-17 05:16:32 +0100
commit8900e3e6f840b95c1c8126f9c283ca5c99f5f4fd (patch)
tree98a756d04cd2d068833a219fe02a7feaf960f87a /dev-libs/popt/popt-1.19.ebuild
parent3b827127cdc24d49f3dbaa82def6c80501d2cd87 (diff)
gentoo auto-resync : 17:09:2022 - 05:16:32
Diffstat (limited to 'dev-libs/popt/popt-1.19.ebuild')
-rw-r--r--dev-libs/popt/popt-1.19.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/popt/popt-1.19.ebuild b/dev-libs/popt/popt-1.19.ebuild
new file mode 100644
index 000000000000..483bb167bd28
--- /dev/null
+++ b/dev-libs/popt/popt-1.19.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="https://github.com/rpm-software-management/popt"
+SRC_URI="http://ftp.rpm.org/${PN}/releases/${PN}-1.x/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.8 )"
+
+src_prepare() {
+ default
+
+ # Unclear what the background to this is, perhaps
+ # https://git.exherbo.org/arbor.git/commit/?id=5545d22d3493279acf7a55246179f818ef22f5fa
+ sed -i -e 's:lt-test1:test1:' tests/testit.sh || die
+
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}