summaryrefslogtreecommitdiff
path: root/dev-libs/polylib/polylib-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/polylib/polylib-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/polylib/polylib-9999.ebuild')
-rw-r--r--dev-libs/polylib/polylib-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/polylib/polylib-9999.ebuild b/dev-libs/polylib/polylib-9999.ebuild
new file mode 100644
index 000000000000..5fcb5a6a7ab8
--- /dev/null
+++ b/dev-libs/polylib/polylib-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+ http://repo.or.cz/r/${PN}.git"
+EGIT_BOOTSTRAP="eautoreconf && cd cln && eautoreconf"
+inherit git-2 autotools eutils
+
+DESCRIPTION="ppl port of cloog"
+HOMEPAGE="http://icps.u-strasbg.fr/polylib/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ git-2_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch
+ # strip LDFLAGS from pkgconfig .pc file
+ sed -i '/Libs:/s:@LDFLAGS@::' configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc doc/Changes
+}