summaryrefslogtreecommitdiff
path: root/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
index 1054159a937a..90dbbbf5b19e 100644
--- a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
@@ -53,19 +53,27 @@ src_compile() {
default
if use perl; then
- cd perl
+ cd perl || die
# configure needs the ossp-uuid.la generated by `make` in $S
perl-module_src_configure
perl-module_src_compile
fi
}
+src_test() {
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${S}/.libs" # required for the perl-bindings to load the (correct) library
+ default
+
+ use perl && emake -C perl test
+}
+
src_install() {
local DOCS=( AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS )
default
unset DOCS #unset so that other eclasses don't try to install them and possibly fail
+
if use perl ; then
- cd perl
+ cd perl || die
perl-module_src_install
fi
@@ -75,10 +83,3 @@ src_install() {
mv "${ED}/usr/share/man/man3"/uuid.3{,ossp}
mv "${ED}/usr/share/man/man3"/uuid++.3{,ossp}
}
-
-src_test() {
- export LD_LIBRARY_PATH="${S}/.libs" # required for the perl-bindings to load the (correct) library
- default
-
- use perl && emake -C perl test
-}