summaryrefslogtreecommitdiff
path: root/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
index 335448aba2c5..7a9a0a1c12aa 100644
--- a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
MY_P="uuid-${PV}"
@@ -16,13 +16,17 @@ S="${WORKDIR}/${MY_P}"
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="+cxx perl static-libs test"
+RESTRICT="!test? ( test )"
-DEPEND="perl? ( dev-lang/perl test? ( virtual/perl-Test-Simple ) )"
+DEPEND="
+ perl? (
+ dev-lang/perl
+ test? ( virtual/perl-Test-Simple )
+ )"
RDEPEND="perl? ( dev-lang/perl:= )"
BDEPEND="perl? ( dev-lang/perl )"
-RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}/${P}-gentoo-r1.patch"
@@ -67,18 +71,19 @@ src_test() {
}
src_install() {
- local DOCS=( AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS )
default
- unset DOCS #unset so that other eclasses don't try to install them and possibly fail
+ dodoc BINDINGS HISTORY OVERVIEW PORTING SEEALSO USERS
if use perl ; then
cd perl || die
perl-module_src_install
fi
- use static-libs || rm -rf "${ED}"/usr/lib*/*.la
+ find "${ED}" -name '*.la' -delete || die
- mv "${ED}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
- mv "${ED}/usr/share/man/man3"/uuid.3{,ossp}
- mv "${ED}/usr/share/man/man3"/uuid++.3{,ossp}
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig/{,ossp-}uuid.pc || die
+ mv "${ED}"/usr/share/man/man3/uuid.3{,ossp} || die
+ if use cxx; then
+ mv "${ED}"/usr/share/man/man3/uuid++.3{,ossp} || die
+ fi
}