summaryrefslogtreecommitdiff
path: root/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch')
-rw-r--r--dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
new file mode 100644
index 000000000000..a4fade8b088b
--- /dev/null
+++ b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
@@ -0,0 +1,24 @@
+--- tmp/uuid-1.6.2/perl/Makefile.PL 2007-01-01 18:13:18.000000000 +0000
++++ uuid-1.6.2/perl/Makefile.PL 2011-01-07 11:54:23.521585547 +0000
+@@ -33,9 +33,9 @@
+ use ExtUtils::MakeMaker;
+
+ # determine source directory
+-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
+- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
+- or die "no source directory found (where libuuid.la is located)";
++my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
++ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
++ or die "no source directory found (where libossp-uuid.la is located)";
+
+ # determine extra build options
+ my $compat = 0;
+@@ -47,7 +47,7 @@
+ VERSION_FROM => 'uuid.pm',
+ ABSTRACT_FROM => 'uuid.pod',
+ PREREQ_PM => {},
+- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
++ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
+ DEFINE => '',
+ INC => "-I. -I$srcdir",
+ PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',