summaryrefslogtreecommitdiff
path: root/dev-libs/openssl/openssl-3.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 21:52:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 21:52:41 +0100
commit67efaff61522aeb024152ab6cddf7c40ffacb530 (patch)
tree294409103a6f391c6c9d317b2dde60cbf1f035e7 /dev-libs/openssl/openssl-3.1.3.ebuild
parentf827ced0163cc11d6d35e2d4e2c8a7ab3fd6482a (diff)
gentoo auto-resync : 19:10:2023 - 21:52:41
Diffstat (limited to 'dev-libs/openssl/openssl-3.1.3.ebuild')
-rw-r--r--dev-libs/openssl/openssl-3.1.3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/openssl/openssl-3.1.3.ebuild b/dev-libs/openssl/openssl-3.1.3.ebuild
index 67cd58d980dc..a89ece323f28 100644
--- a/dev-libs/openssl/openssl-3.1.3.ebuild
+++ b/dev-libs/openssl/openssl-3.1.3.ebuild
@@ -224,16 +224,18 @@ multilib_src_test() {
}
multilib_src_install() {
- emake DESTDIR="${D}" install_sw
+ # Only -j1 is supported for the install targets:
+ # https://github.com/openssl/openssl/issues/21999#issuecomment-1771150305
+ emake DESTDIR="${D}" -j1 install_sw
if use fips; then
- emake DESTDIR="${D}" install_fips
+ emake DESTDIR="${D}" -j1 install_fips
# Regen this in pkg_preinst, bug 900625
rm "${ED}${SSL_CNF_DIR}"/fipsmodule.cnf || die
fi
if multilib_is_native_abi; then
- emake DESTDIR="${D}" install_ssldirs
- emake DESTDIR="${D}" DOCDIR='$(INSTALLTOP)'/share/doc/${PF} install_docs
+ emake DESTDIR="${D}" -j1 install_ssldirs
+ emake DESTDIR="${D}" DOCDIR='$(INSTALLTOP)'/share/doc/${PF} -j1 install_docs
fi
# This is crappy in that the static archives are still built even