summaryrefslogtreecommitdiff
path: root/dev-libs/openpace/openpace-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
commit0e7ef53ddcc33809bcb2644d3649617113b78ea3 (patch)
treef1665ac62e9addb6b2c3663e7f7507b84c82a43e /dev-libs/openpace/openpace-1.1.2.ebuild
parent55a7866dd6169a108d3a9e8d6696a970dea8a0b6 (diff)
gentoo auto-resync : 23:09:2022 - 17:30:17
Diffstat (limited to 'dev-libs/openpace/openpace-1.1.2.ebuild')
-rw-r--r--dev-libs/openpace/openpace-1.1.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/openpace/openpace-1.1.2.ebuild b/dev-libs/openpace/openpace-1.1.2.ebuild
new file mode 100644
index 000000000000..308f5d566c47
--- /dev/null
+++ b/dev-libs/openpace/openpace-1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Cryptographic library for EAC version 2"
+HOMEPAGE="https://frankmorgner.github.io/openpace"
+SRC_URI="https://github.com/frankmorgner/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig"
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl.patch
+ "${FILESDIR}"/${P}-openssl-3.0.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-openssl-install \
+ --disable-go \
+ --disable-java \
+ --disable-python \
+ --disable-ruby
+}
+
+src_compile() {
+ # not running just 1 job causes a race condition that causes a linking error
+ emake -j1
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}