summaryrefslogtreecommitdiff
path: root/dev-libs/openct/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-libs/openct/files
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-libs/openct/files')
-rw-r--r--dev-libs/openct/files/openct-0.6.20-automake.patch24
-rw-r--r--dev-libs/openct/files/openct-0.6.20-slibtool.patch34
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/openct/files/openct-0.6.20-automake.patch b/dev-libs/openct/files/openct-0.6.20-automake.patch
new file mode 100644
index 000000000000..451af6a8a50e
--- /dev/null
+++ b/dev-libs/openct/files/openct-0.6.20-automake.patch
@@ -0,0 +1,24 @@
+From 86abf3cbddbdc590dbb2ff5b0bda263e42595b88 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 10 Oct 2012 08:48:02 +0000
+Subject: [PATCH] build: fix issue with latest automake
+
+---
+ etc/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/etc/Makefile.am b/etc/Makefile.am
+index ff66d4e..dc00f47 100644
+--- a/etc/Makefile.am
++++ b/etc/Makefile.am
+@@ -30,8 +30,8 @@ dist_noinst_DATA += openct.usermap
+ endif
+
+
+-sysconf_DATA=#required in order to create dir
+-install-exec-hook: install-sysconfDATA openct.conf
++install-exec-hook: openct.conf
++ $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
+ if [ -f "$(DESTDIR)$(sysconfdir)/openct.conf" ]; then \
+ $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf.new"; \
+ else \
diff --git a/dev-libs/openct/files/openct-0.6.20-slibtool.patch b/dev-libs/openct/files/openct-0.6.20-slibtool.patch
new file mode 100644
index 000000000000..0c0af2e1bd94
--- /dev/null
+++ b/dev-libs/openct/files/openct-0.6.20-slibtool.patch
@@ -0,0 +1,34 @@
+From f329c2663bde748d4a8fc462a1ea7bbc4ab47b36 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 27 Sep 2013 23:27:24 +0300
+Subject: [PATCH] build: use newer libtool -shared option
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/ctapi/Makefile.am | 2 +-
+ src/pcsc/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ctapi/Makefile.am b/src/ctapi/Makefile.am
+index 25627a3..c837820 100644
+--- a/src/ctapi/Makefile.am
++++ b/src/ctapi/Makefile.am
+@@ -8,4 +8,4 @@ libopenctapi_la_LIBADD = $(top_builddir)/src/ct/libopenct.la
+ libopenctapi_la_CFLAGS = $(AM_CFLAGS) \
+ -I$(top_srcdir)/src/include \
+ -I$(top_builddir)/src/include
+-libopenctapi_la_LDFLAGS = -avoid-version -no-undefined --module
++libopenctapi_la_LDFLAGS = -avoid-version -no-undefined -module -shared
+diff --git a/src/pcsc/Makefile.am b/src/pcsc/Makefile.am
+index 9986621..6aff8b8 100644
+--- a/src/pcsc/Makefile.am
++++ b/src/pcsc/Makefile.am
+@@ -5,7 +5,7 @@ lib_LTLIBRARIES = openct-ifd.la
+ endif
+
+ openct_ifd_la_SOURCES = pcsc.c
+-openct_ifd_la_LDFLAGS = -module -avoid-version -no-undefined
++openct_ifd_la_LDFLAGS = -module -shared -avoid-version -no-undefined
+ openct_ifd_la_LIBADD = $(PCSC_LIBS) $(top_builddir)/src/ctapi/libopenctapi.la
+ openct_ifd_la_CFLAGS = $(AM_CFLAGS) \
+ -I$(top_srcdir)/src/include \