summaryrefslogtreecommitdiff
path: root/dev-libs/opencryptoki
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/opencryptoki
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/opencryptoki')
-rw-r--r--dev-libs/opencryptoki/Manifest2
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.6.1-r1.ebuild (renamed from dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild)31
2 files changed, 17 insertions, 16 deletions
diff --git a/dev-libs/opencryptoki/Manifest b/dev-libs/opencryptoki/Manifest
index 2be5a03ee0d8..6930d9ca9f48 100644
--- a/dev-libs/opencryptoki/Manifest
+++ b/dev-libs/opencryptoki/Manifest
@@ -1,4 +1,4 @@
AUX pkcsslotd.init.2 664 BLAKE2B de96f878e55ce5346a3846c99deae28e540964cf4a7dcd42e2893cf540484fa6b3bd914400c2fd39067e8cfc29d030691fd0e4e4fb83b229bc2c03085e5df2f0 SHA512 3bdc6d2f87b2209163ad08915afa900f9c14324d3e48619cffe462c3c651996fe0e0b485eb6331552fcb22297cfa7bda9b6440a8bad9419d6835a047f1b2a0e9
DIST opencryptoki-3.6.1.tgz 1068197 BLAKE2B 0e7d867bd21863f56471ac2c8664148e5a6988ffc30e71feaf960245a1908d676c1791f2b751de4bdd694096bf7360af3a8f79df895eef1b8f61391aba09aaad SHA512 1874fabba6d3da49596622c7f8142a37329df95f129cb08319bb3900a944dde1ae5ce9d845d400726f4bda4579c730012b9bfd6c69c6d5a16b1f75b28a0ba4af
-EBUILD opencryptoki-3.6.1.ebuild 3100 BLAKE2B 8775c159cf881eaa7d3b2f10125c84b34ed008490e06f7addf110b9cf4a27a884f02a43c32bdc31508de0f0dc51afadb1e5842f9d28a84966223be2a85158046 SHA512 d44e5d8f572b380245a9fa330fb423867e7cc1118a3c3201cb41414768510e3cb34ee513c7be6af166461b73f60c84c843800af400d1ff276501b1f11fb23512
+EBUILD opencryptoki-3.6.1-r1.ebuild 3103 BLAKE2B 57e38cc7df3d6f198f471118bd839204223171aaeb0449f0ddb89e0970794cbc599d2589df320a329af38bf97c7d5d6cf20a6e81478b70901cca6413b58424f1 SHA512 97d7e7fa252b534e3ae696b6f4f365dcd993d12b4c2f2841e8a897a4f60ccafd57538cbfd928d621c7ddda666c1e33541ee48bdc2bb281fd02dbab89e92e7aef
MISC metadata.xml 375 BLAKE2B e00a1038bf53c0b8a93ee545e4674dcd7081a70874f5a3fe94794cf65b47d34cd94ccf512c8340b8b84170205840afbdc785dcd49b8391cdfdb655830a483c6b SHA512 fb29b7702172d4e47fe7cb29ec502f9ff0e1f713181ea5af7834a776b2844f4f5d51972764d4bf62088325c498d48a17479856ba5d24ef050af3d3f835c58352
diff --git a/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild b/dev-libs/opencryptoki/opencryptoki-3.6.1-r1.ebuild
index f3666b16096e..a391a24d3fa4 100644
--- a/dev-libs/opencryptoki/opencryptoki-3.6.1.ebuild
+++ b/dev-libs/opencryptoki/opencryptoki-3.6.1-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools multilib flag-o-matic user
+inherit autotools flag-o-matic
DESCRIPTION="PKCS#11 provider cryptographic hardware"
HOMEPAGE="https://sourceforge.net/projects/opencryptoki"
SRC_URI="mirror://sourceforge/opencryptoki/${PV}/${P}.tgz"
+S="${WORKDIR}/${PN}"
# Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
# token sources are under CPL-1.0 already.
@@ -16,10 +17,15 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
IUSE="debug libressl +tpm"
-RDEPEND="tpm? ( app-crypt/trousers )
+DEPEND="
+ tpm? ( app-crypt/trousers )
!libressl? ( >=dev-libs/openssl-1.1.0:0= )
- libressl? ( >=dev-libs/libressl-2.7.0:0= )"
-DEPEND="${RDEPEND}"
+ libressl? ( >=dev-libs/libressl-2.7.0:0= )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/pkcs11
+"
DOCS=(
README AUTHORS FAQ TODO
@@ -31,12 +37,6 @@ DOCS=(
# things that we're not interested to.
RESTRICT=test
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- enewgroup pkcs11
-}
-
src_prepare() {
default
mv configure.in configure.ac || die
@@ -74,24 +74,25 @@ src_configure() {
src_install() {
default
+
find "${ED}" -name '*.la' -delete || die
# Install libopencryptoki in the standard directory for libraries.
mv "${ED}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${ED}"/usr/$(get_libdir) || die
- rm "${ED}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
+ rm "${ED}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so || die
dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
# Remove compatibility symlinks as we _never_ required those and
# they seem unused even upstream.
- find "${ED}" -name 'PKCS11_*' -delete
+ find "${ED}" -name 'PKCS11_*' -delete || die
# We replace their ld.so and init files (mostly designed for RedHat
# as far as I can tell) with our own replacements.
- rm -rf "${ED}"/etc/ld.so.conf.d "${ED}"/etc/rc.d
+ rm -rf "${ED}"/etc/ld.so.conf.d "${ED}"/etc/rc.d || die
# make sure that we don't modify the init script if the USE flags
# are enabled for the needed services.
- cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init
+ cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init || die
use tpm || sed -i -e '/use tcsd/d' "${T}"/pkcsslotd.init
newinitd "${T}/pkcsslotd.init" pkcsslotd