summaryrefslogtreecommitdiff
path: root/dev-libs/oniguruma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-libs/oniguruma
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/Manifest3
-rw-r--r--dev-libs/oniguruma/files/oniguruma-6.9.3-fix-heap-buffer-overflow-php78633.patch25
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.3-r2.ebuild (renamed from dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild)5
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
index 4dd6cfcb8ebd..62cc75bf962b 100644
--- a/dev-libs/oniguruma/Manifest
+++ b/dev-libs/oniguruma/Manifest
@@ -1,4 +1,5 @@
AUX oniguruma-6.9.3-fix-heap-buffer-overflow-php78559.patch 454 BLAKE2B 8ec384d21dd283cabd7b3a567bacc2375c489a78f71ccf4373a88b707c31bee0ca2f83c538e1d760e52314c6ecb168c2cf80a5049eb96d993ec08bb38136f641 SHA512 2fd3df7ad7c7bd75967250ec89153c0c6c6859f2833419e134c5aa6463cfd26bb9e7e2a1121cf59973bd6b3451476743b1fba79dbf61cb5cf45040ea13d67311
+AUX oniguruma-6.9.3-fix-heap-buffer-overflow-php78633.patch 777 BLAKE2B 06d47037678d7e6bf757f879e319545a434d9301ab31045132ca3ae112e8f86f2797c544533b031536d40646859a4a3bc5d66abafb963b931b32b2b3aa8ccbf9 SHA512 03ea9386547b7f7c19d1067b0ec4dede30c3656d2403ac60338d6aa3bf1ceca1a80eb19a08fa83bbc4766ffc63c4871bd91c37731b259f2395839e724f3314bf
DIST onig-6.9.3.tar.gz 902349 BLAKE2B 4b20290a2d72b638b13a2e2edc89e072a8d17f89f6a273b58d0e408d01726ace948dd390bb2f4c478b87d01bed9fa344a4933060736a40981219301529957aaa SHA512 6b038879cb9cbe8cc756159eb53125e1d4dc7365ca434d07b99a59f3602987e573da120506bbd88d0f51dcdde5866bfa48d45803f8869503726c4d9a47d62861
-EBUILD oniguruma-6.9.3-r1.ebuild 1044 BLAKE2B 72cda1c817606528a2b81cc4333aa8df356761cc4781d645a48c42cdff72a1931ed30ab1aefe702c921d2a018abc66bdd4ecabbe56825cf937cd2003f3380580 SHA512 ba2751c367251fa344a4a7aef978d752d7158c4d6d240ce3eb167e2b1a7b838ca02ccb5b12d4f7f1eb2e1aff8e81072a1ccd02b0c2337b1d35adc74d49f2882c
+EBUILD oniguruma-6.9.3-r2.ebuild 1112 BLAKE2B fde34ed55491542010421c2b6510edb7ae7d00d88234202cc527de6ce8b73926d979a049577215f63975a7c02da48bea7fb832ba8d5821a9f23664ab21374c13 SHA512 ec78dc10570e912890d4cd08efa9adbf1e4a1586a005930d536faa71db67adad17621770c073c925594d70b6bc7b0e2c9a4435ea0b224b62d581fdde961bf193
MISC metadata.xml 799 BLAKE2B 862b6b8ec3f6707fa10fd2cb79858481e9537a542632c26828b52ea7afc099c315e3cdac59fc3c55aa384288735e653104a3fe7abd165482d1c443ea128b24a3 SHA512 62bb6686582652a9215a0548d3400e0f864e86040625dc608eea9d644937738b6fcb9c060034a85d27b31797068c05dcf78b18d8b411c3f8b3ef96e2cec99d2c
diff --git a/dev-libs/oniguruma/files/oniguruma-6.9.3-fix-heap-buffer-overflow-php78633.patch b/dev-libs/oniguruma/files/oniguruma-6.9.3-fix-heap-buffer-overflow-php78633.patch
new file mode 100644
index 000000000000..e946a57d648f
--- /dev/null
+++ b/dev-libs/oniguruma/files/oniguruma-6.9.3-fix-heap-buffer-overflow-php78633.patch
@@ -0,0 +1,25 @@
+https://bugs.php.net/bug.php?id=78633
+https://github.com/kkos/oniguruma/commit/15c4228aa2ffa02140a99912dd3177df0b1841c6
+
+--- a/src/regcomp.c
++++ b/src/regcomp.c
+@@ -734,8 +734,8 @@ add_compile_string(UChar* s, int mb_len, int str_len,
+ COP(reg)->exact_n.s = p;
+ }
+ else {
++ xmemset(COP(reg)->exact.s, 0, sizeof(COP(reg)->exact.s));
+ xmemcpy(COP(reg)->exact.s, s, (size_t )byte_len);
+- COP(reg)->exact.s[byte_len] = '\0';
+ }
+
+ return 0;
+--- a/src/regexec.c
++++ b/src/regexec.c
+@@ -2889,6 +2889,7 @@ match_at(regex_t* reg, const UChar* str, const UChar* end,
+ DATA_ENSURE(0);
+ q = lowbuf;
+ while (len-- > 0) {
++ if (ps >= endp) goto fail;
+ if (*ps != *q) goto fail;
+ ps++; q++;
+ }
diff --git a/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild b/dev-libs/oniguruma/oniguruma-6.9.3-r2.ebuild
index b3b9800c1cb8..8a716c7a03eb 100644
--- a/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild
+++ b/dev-libs/oniguruma/oniguruma-6.9.3-r2.ebuild
@@ -16,7 +16,10 @@ SLOT="0/5"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="crnl-as-line-terminator static-libs"
-PATCHES=( "${FILESDIR}"/${PN}-6.9.3-fix-heap-buffer-overflow-php78559.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.9.3-fix-heap-buffer-overflow-php78559.patch
+ "${FILESDIR}"/${PN}-6.9.3-fix-heap-buffer-overflow-php78633.patch
+)
S="${WORKDIR}/${MY_P}"