summaryrefslogtreecommitdiff
path: root/dev-libs/oniguruma/oniguruma-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/oniguruma/oniguruma-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/oniguruma/oniguruma-9999.ebuild')
-rw-r--r--dev-libs/oniguruma/oniguruma-9999.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/dev-libs/oniguruma/oniguruma-9999.ebuild b/dev-libs/oniguruma/oniguruma-9999.ebuild
index 8efae9394402..4c0eebf2c0ca 100644
--- a/dev-libs/oniguruma/oniguruma-9999.ebuild
+++ b/dev-libs/oniguruma/oniguruma-9999.ebuild
@@ -1,34 +1,27 @@
-# Copyright 2003-2019 Gentoo Authors
+# Copyright 2003-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit multilib-minimal
if [[ "${PV}" == "9999" ]]; then
inherit autotools git-r3
-
EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+ S="${WORKDIR}/onig-${PV}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
DESCRIPTION="Regular expression library for different character encodings"
HOMEPAGE="https://github.com/kkos/oniguruma"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
-fi
LICENSE="BSD-2"
SLOT="0/5"
-KEYWORDS=""
IUSE="crnl-as-line-terminator static-libs"
-if [[ "${PV}" != "9999" ]]; then
- S="${WORKDIR}/onig-${PV}"
-fi
-
-DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+DOCS=( AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES} )
src_prepare() {
default
@@ -46,5 +39,5 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
- find "${D}" -name "*.la" -type f -delete || die
+ find "${ED}" -name "*.la" -type f -delete || die
}