summaryrefslogtreecommitdiff
path: root/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
commit5a165c60b9b8c4847067cb83b4be7da785d01f93 (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild
parenta5b65c81168c90928784a1e92cda84ed5d6b9eb3 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild')
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild b/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild
new file mode 100644
index 000000000000..2b0d346fc447
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="onig-${PV}"
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.9.3-fix-heap-buffer-overflow-php78559.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name "*.la" -type f -delete || die
+}