summaryrefslogtreecommitdiff
path: root/dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
commitc4b414ba84991b36b62c066b701385eaf44cdd49 (patch)
tree5cbdb7a51f1abb965fdfe90b686f8130e100afaa /dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild
parentea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (diff)
gentoo auto-resync : 31:12:2022 - 20:20:25
Diffstat (limited to 'dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild')
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild b/dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild
deleted file mode 100644
index e4d106dd1969..000000000000
--- a/dev-libs/ocl-icd/ocl-icd-2.3.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-inherit autotools flag-o-matic multilib-minimal ruby-single
-
-DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
-HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
-SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-# Does nothing now but by keeping it here we avoid having to have virtual/opencl
-# handle ebuilds both with and without this flag.
-IUSE="+khronos-headers"
-
-BDEPEND="${RUBY_DEPS}"
-DEPEND=">=dev-util/opencl-headers-2021.04.29"
-RDEPEND="${DEPEND}
- !app-eselect/eselect-opencl
- !dev-libs/opencl-icd-loader"
-
-PATCHES=(
- "${FILESDIR}"/${P}-new-headers.patch
-)
-
-src_prepare() {
- replace-flags -Os -O2 # bug 646122
-
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- # dev-util/opencl-headers ARE official Khronos Group headers, what this option
- # does is disable the use of the bundled ones
- ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers \
- --enable-custom-vendordir="${EPREFIX}/etc/OpenCL/vendors"
-}
-
-multilib_src_compile() {
- local candidates=(${USE_RUBY})
- local ruby=
- for (( idx=${#candidates[@]}-1 ; idx>=0 ; idx-- )) ; do
- if ${candidates[idx]} --version &> /dev/null; then
- ruby=${candidates[idx]} && break
- fi
- done
- [[ -z ${ruby} ]] && die "No ruby executable found"
-
- emake RUBY=${ruby}
-}
-
-multilib_src_install() {
- default
-
- # Drop .la files
- find "${ED}" -name '*.la' -delete || die
-}