summaryrefslogtreecommitdiff
path: root/dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild')
-rw-r--r--dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild b/dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild
new file mode 100644
index 000000000000..353b0a1d9722
--- /dev/null
+++ b/dev-libs/nsgenbind/nsgenbind-0.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit netsurf
+
+DESCRIPTION="Generate Javascript-to-DOM bindings from w3c webidl files"
+HOMEPAGE="http://www.netsurf-browser.org/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+BDEPEND="
+ dev-util/netsurf-buildsystem
+ virtual/yacc"
+
+_emake() {
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=binary $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}