summaryrefslogtreecommitdiff
path: root/dev-libs/npth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
commit94b475013eb88e152032d5f8c684a7d9ce91e319 (patch)
tree09d40138872fbeea80b96af571a1da4de80bcf73 /dev-libs/npth
parent8d3527b916ca7e0a2c8d9b8d064253a2eda02c1f (diff)
gentoo auto-resync : 03:01:2024 - 13:56:25
Diffstat (limited to 'dev-libs/npth')
-rw-r--r--dev-libs/npth/Manifest1
-rw-r--r--dev-libs/npth/npth-1.6-r2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/npth/Manifest b/dev-libs/npth/Manifest
index 945ee708507c..56a0680a7d89 100644
--- a/dev-libs/npth/Manifest
+++ b/dev-libs/npth/Manifest
@@ -1,3 +1,4 @@
DIST npth-1.6.tar.bz2 300486 BLAKE2B 665fdb2f4cbe59750b6b4b7c2701ee80a23a122df10c9f8be47c4af5f3bf5968f709637ab3f4878bb68609752fbb6ce1364e109fdfeba64e4db258733a33f3fc SHA512 2ed1012e14a9d10665420b9a23628be7e206fd9348111ec751349b93557ee69f1176bcf7e6b195b35b1c44a5e0e81ee33b713f03d79a33d1ecd9037035afeda2
EBUILD npth-1.6-r1.ebuild 1026 BLAKE2B e547f6fd629ea0aa193776e73327eff3cdcd0cdbcc3b693985f814477e34cc3db67786dad076380bb8b753a342eaad4d1cfe7548613c279b57425cc984643042 SHA512 c5568a25e529ca1af2a1a0d99f4b4c37d45bc3bc073617ba5ec712063176dcdea61b6be280783d8a00d830244f4acc26e6bbc9eaf6f105fe308ca80e575090c7
+EBUILD npth-1.6-r2.ebuild 792 BLAKE2B 7942cb2e49768d80be40fcb76e2c8ca3ac9f0325de06541e3b22d1521e4f181e3b2f76fa784e0ffbaac329eb3e3a86974fbe83367dc8a2f807de27565a2b487d SHA512 df08937672e778acb4838b8fe323b42807fbc9b92aeb3f828547538fc6ebb1dafa7fa72daa6abe73bcaa28c83f8f02c78c9d4f44281f7bd978238fb495f70eb6
MISC metadata.xml 248 BLAKE2B 8635d7e87f0f2de85f967cadf3324aecfe013decb6f6dbc4338f2bdbb3fad5b61b5a58780f4c6d4759ec51a1b89af067b689b716ad34c71b6f09887536da1493 SHA512 fb771f3d411fc1ab3e5600af41fc51d254b7c2c4d057e80e582fcf2f355f35204e7f61dba852bed35f21c87f2063d7ee0d3a5628395e4ed945955a818deeb37c
diff --git a/dev-libs/npth/npth-1.6-r2.ebuild b/dev-libs/npth/npth-1.6-r2.ebuild
new file mode 100644
index 000000000000..71d952cdae8c
--- /dev/null
+++ b/dev-libs/npth/npth-1.6-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}