summaryrefslogtreecommitdiff
path: root/dev-libs/npth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /dev-libs/npth
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'dev-libs/npth')
-rw-r--r--dev-libs/npth/Manifest2
-rw-r--r--dev-libs/npth/npth-1.6-r1.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-libs/npth/Manifest b/dev-libs/npth/Manifest
index 95a8f4fcedc0..e7f96590d63d 100644
--- a/dev-libs/npth/Manifest
+++ b/dev-libs/npth/Manifest
@@ -1,3 +1,3 @@
DIST npth-1.6.tar.bz2 300486 BLAKE2B 665fdb2f4cbe59750b6b4b7c2701ee80a23a122df10c9f8be47c4af5f3bf5968f709637ab3f4878bb68609752fbb6ce1364e109fdfeba64e4db258733a33f3fc SHA512 2ed1012e14a9d10665420b9a23628be7e206fd9348111ec751349b93557ee69f1176bcf7e6b195b35b1c44a5e0e81ee33b713f03d79a33d1ecd9037035afeda2
-EBUILD npth-1.6-r1.ebuild 780 BLAKE2B 71a78816a5a6ca2f8c02377f4a31cb0badfe7dc1306beb31fdba151bb77770b810de7c61eac14cf49f5652a7ea92899f6a0be32dcf324e11fd6f3d8f832447fb SHA512 2fb1b035d9666e10d50ba33b421041ec4e5a0d2279a31fecc1a253c15355978862e752af21fb80c0c70beed092d5276df968c9cb3308fa2ca47ff3c8bae0fbb0
+EBUILD npth-1.6-r1.ebuild 1070 BLAKE2B ae01898ebbec183e5ab0f5147581f52dfc50a83e47afaf582466b4351c1b2b2c8fa81ac1ce8c7fd9a748e31870abbc688823b6b1ba02cc944879180864a159c7 SHA512 422f88da6729a3bac7fd22a9b271a360cdf0057ea063f58e4e631165c7c7d66a11bd131d3ac9095b648bc94de2aee097d6cd0482dd6a79a35cc5f08872d52927
MISC metadata.xml 248 BLAKE2B 8635d7e87f0f2de85f967cadf3324aecfe013decb6f6dbc4338f2bdbb3fad5b61b5a58780f4c6d4759ec51a1b89af067b689b716ad34c71b6f09887536da1493 SHA512 fb771f3d411fc1ab3e5600af41fc51d254b7c2c4d057e80e582fcf2f355f35204e7f61dba852bed35f21c87f2063d7ee0d3a5628395e4ed945955a818deeb37c
diff --git a/dev-libs/npth/npth-1.6-r1.ebuild b/dev-libs/npth/npth-1.6-r1.ebuild
index bb3c8b84c723..00a8ae2ae917 100644
--- a/dev-libs/npth/npth-1.6-r1.ebuild
+++ b/dev-libs/npth/npth-1.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="New GNU Portable Threads Library"
HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
@@ -21,6 +21,13 @@ src_prepare() {
}
src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
econf \
--disable-static \
$(use_enable test tests)