summaryrefslogtreecommitdiff
path: root/dev-libs/nettle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-libs/nettle
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/Manifest2
-rw-r--r--dev-libs/nettle/nettle-3.4.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/nettle/Manifest b/dev-libs/nettle/Manifest
index b61f3e2a1ae8..706c7de58256 100644
--- a/dev-libs/nettle/Manifest
+++ b/dev-libs/nettle/Manifest
@@ -1,3 +1,5 @@
+DIST nettle-3.4.1.tar.gz 1947053 BLAKE2B 354318c46c28aeaaca611abe70298024ec12ff70aed53c741e43c1b5373361e5cffb03df7b8e86ef103a3b7770b2b4fe39fbca00b128f2b7ec810b3a4d9fd0fd SHA512 26aefbbe9927e90e28f271e56d2ba876611831222d0e1e1a58bdb75bbd50934fcd84418a4fe47b845f557e60a9786a72a4de2676c930447b104f2256aca7a54f
DIST nettle-3.4.tar.gz 1935069 BLAKE2B b73c88236c8233360607a6ed65cd4f6d19bfbbf683b46149326ce3440bf0a42b8add69de5c64145720163b1095fdab3cb8bf410c2ef727d0ea4fb58391ff0f14 SHA512 3bea3aabd2c99cc42d084a94fd6b0b5dbdb24cd6c7020271a6ee87a81a904b21b21756f590cb1afdf2e85fd1cb59e5c3651c5c4032e30204e7ea6f8801d1ea3b
+EBUILD nettle-3.4.1.ebuild 1733 BLAKE2B 28564bdcaa9f8b379c5acc98050ff3a019ff12b85a05956acc575be4e5e094b8cae87a86b06bedc5d6561975890a2df0b6c0873839f5ae33130987f0ebc025bb SHA512 c636e48bf6a8a44d3eba3ebbb8c3811cedeab36264c7532f5454a2955b081c41b0fd9f5c17412d55045200e533198febacb859cca392883d388bd42afcd6d441
EBUILD nettle-3.4.ebuild 1725 BLAKE2B 71eb0b92783f817ab7eeb4c0a29445e65a56b9cb6cc07a7269c3401c34f605bb49589aa999c4e2a35330b4b4dc4a324cd2c860bfcf0164a79118330b40a1160b SHA512 dcfd2513e10dc106274500d3531b1b629ded8ac9c85d37ee5c150a32f2507fc1045d269b394d91b508a991525f271637048937a4ddf9a58613b35dbbfddb32f4
MISC metadata.xml 236 BLAKE2B a7bb92e6d53f7252ee56a885bf098930e228a76a75bca119358ca860901ceeecccc43efe5279c54250ebda58f77ae9c97d2ae540d8b399283cb3aa348111fcd2 SHA512 5f6cd6a85527534d5de7118de5af212ee3044c8c5530a7f7087a28074a2d4ab7be1728325bd985adc063dc795d3cf2b1c4e58a4c4c4ec02d739bd4bbc544ef08
diff --git a/dev-libs/nettle/nettle-3.4.1.ebuild b/dev-libs/nettle/nettle-3.4.1.ebuild
new file mode 100644
index 000000000000..bcd2711cdabb
--- /dev/null
+++ b/dev-libs/nettle/nettle-3.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-build multilib-minimal multilib toolchain-funcs
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/6.2" # subslot = libnettle soname version, .2 as broke ABI bug#601512 then fixed
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes"
+
+DEPEND="gmp? ( >=dev-libs/gmp-6.0:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/nettle/nettle-stdint.h
+ /usr/include/nettle/version.h
+)
+
+DOCS=()
+HTML_DOCS=()
+
+pkg_setup() {
+ use doc && DOCS+=(
+ nettle.pdf
+ )
+ use doc && HTML_DOCS+=(
+ nettle.html
+ )
+}
+
+src_prepare() {
+ default
+
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # --disable-openssl bug #427526
+ ECONF_SOURCE="${S}" econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-openssl \
+ --disable-fat \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ $(tc-is-static-only && echo --disable-shared) \
+ $(use_enable doc documentation) \
+ $(use_enable neon arm-neon) \
+ $(use_enable cpu_flags_x86_aes x86-aesni)
+}