summaryrefslogtreecommitdiff
path: root/dev-libs/nanomsg/nanomsg-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
commit796cae72cf9ed18ba01256ac1f83a686a2a76036 (patch)
tree5ca737a2562d8c0a09fcfacd81d1f9004df37b00 /dev-libs/nanomsg/nanomsg-1.1.2.ebuild
parent20d8e9cfb95a9f054d654ab6405e848807186aa0 (diff)
gentoo resync : 20.11.2017
Diffstat (limited to 'dev-libs/nanomsg/nanomsg-1.1.2.ebuild')
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.1.2.ebuild b/dev-libs/nanomsg/nanomsg-1.1.2.ebuild
new file mode 100644
index 000000000000..d76c8310c051
--- /dev/null
+++ b/dev-libs/nanomsg/nanomsg-1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-multilib
+
+DESCRIPTION="High-performance messaging interface for distributed applications"
+HOMEPAGE="http://nanomsg.org/"
+SRC_URI="https://github.com/nanomsg/nanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/5.0.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( dev-ruby/asciidoctor )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNN_STATIC_LIB=$(usex static-libs ON OFF)
+ )
+ if multilib_is_native_abi; then
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=$(usex doc ON OFF)
+ )
+ else
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=OFF
+ -DNN_ENABLE_TOOLS=OFF
+ -DNN_ENABLE-NANOCAT=OFF
+ )
+ fi
+ cmake-utils_src_configure
+}