summaryrefslogtreecommitdiff
path: root/dev-libs/mps/mps-1.110.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/mps/mps-1.110.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/mps/mps-1.110.0.ebuild')
-rw-r--r--dev-libs/mps/mps-1.110.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/mps/mps-1.110.0.ebuild b/dev-libs/mps/mps-1.110.0.ebuild
new file mode 100644
index 000000000000..da17850546fa
--- /dev/null
+++ b/dev-libs/mps/mps-1.110.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Ravenbrook Memory Pool System"
+
+MY_P="${PN}-kit-${PV}"
+HOMEPAGE="http://www.ravenbrook.com/project/mps/"
+SRC_URI="http://www.ravenbrook.com/project/${PN}/release/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/
+
+src_prepare() {
+ # need to fix CFLAGS, it's still being silly
+ sed -i -e 's/-Werror//' code/g{c,p}.gmk || die "Failed to fix CFLAGS"
+}