summaryrefslogtreecommitdiff
path: root/dev-libs/mpfr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-libs/mpfr
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/Manifest2
-rw-r--r--dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild29
2 files changed, 18 insertions, 13 deletions
diff --git a/dev-libs/mpfr/Manifest b/dev-libs/mpfr/Manifest
index 769827ce3441..b79f83414ae6 100644
--- a/dev-libs/mpfr/Manifest
+++ b/dev-libs/mpfr/Manifest
@@ -13,5 +13,5 @@ DIST mpfr-4.1.0-patch12.patch 6768 BLAKE2B 15ce68eb9941ac5d6544ee18a062cb12026e0
DIST mpfr-4.1.0-patch13.patch 3344 BLAKE2B 1239cf16dfe32a71bb6fc7b156978cd451bcbe4e1b04842fdb3549352a43607d44d58120e38bf448ffd33e36bab7f7cfd4ab65b2eb3aac2fe9bbd86d8f425f5a SHA512 ddd5f54d12584b6e10fd4eba12b8568c5286dba10bd3b5cdd429415b78bc827bd0ed3957bd06ca4c2c63a2f5e877fd9d86eebade8929d61aafe84ace8454d016
DIST mpfr-4.1.0.tar.xz 1525476 BLAKE2B 41d1be0c4b557760f12a4525ad3a84b6e2cd6f0927c935fcfba577ac0490e582d1ae4b581dce58e21e705cf9d7c88373054d7fb7a94bb32c69b339f99a25dc68 SHA512 1bd1c349741a6529dfa53af4f0da8d49254b164ece8a46928cdb13a99460285622d57fe6f68cef19c6727b3f9daa25ddb3d7d65c201c8f387e421c7f7bee6273
EBUILD mpfr-4.1.0-r1.ebuild 1061 BLAKE2B 945f47250941a8eb20ba260e7a15441995c1918064a86572d108067952aa1f02898b6618ec24f2a64494726fc937b25ffc2dc9b33a0c0482feeeea754d5a37da SHA512 694154aa8944576b75ed96c6838de6715461b9cb317ffc945c99c8c78615eefcd8adfcf5051cf9b34e28024c91186233682311658231cc871ca5e41c7c0748a9
-EBUILD mpfr-4.1.0_p13-r1.ebuild 2571 BLAKE2B d6fe812ee6d6eb8c12ae699d8d8659b88edacfca8f5f52529e7cf1afe11125f6f247d24d938b34739296aaabf686481983606651bb661816fc2f67dadd26b7dd SHA512 c11937671cffa02c2b81c4e49c4a11aac1e151ac67729c047a79b4d240fc2f57598184dd5244d428de0371764341e75fe603d10cbcce6e31d6dbfd356f2e3597
+EBUILD mpfr-4.1.0_p13-r1.ebuild 2693 BLAKE2B 91592f5c6cc48809eba0f31068c62f30e0b41f8b49ba9aad2fd94da72ed1782aff39a60761ddd1eef315a46df8e11b05de832c3098b103ccc4cfa47de8949e12 SHA512 bc3b6e72ba18c9f6d700ca9a7edad57a483901c161cea915bb82698ca371235d25e915107b319146b8b014526bb7c48222bf6365c1415c0895ec19fcb66fe8ae
MISC metadata.xml 262 BLAKE2B fe330d67755784d14f5c5d664d7127d3cdb9edfab55b907ae3632f434d86323604f5095e1c1a9fbd169ae7a4cbb38f359e55f75047531786247c0674a4a53715 SHA512 3bcaca4e730edeed06fed73e79a5ce0a3358174672735ea4b27240c6c421ac9c33bc2b63a31e596fe1bbb6b1816c16cbc7ef4f258ca906ba04ea7db4aedc86b9
diff --git a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
index 0ac19f7cd365..14f2319304bc 100644
--- a/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
+++ b/dev-libs/mpfr/mpfr-4.1.0_p13-r1.ebuild
@@ -12,6 +12,7 @@ inherit multilib-minimal
# https://archives.gentoo.org/gentoo-releng-autobuilds/message/c2dd39fc4ebc849db6bb0f551739e2ed
MY_PV=$(ver_cut 1-3)
MY_PATCH=$(ver_cut 5-)
+MY_PATCHES=()
MY_P=${PN}-${MY_PV}
DESCRIPTION="Library for multiple-precision floating-point computations with exact rounding"
@@ -21,12 +22,11 @@ if [[ ${PV} == *_p* ]] ; then
# If this is a patch release, we have to download each of the patches:
# -_pN = N patches
# - patch file names are like: patch01, patch02, ..., patch10, patch12, ..
+ #
# => name the ebuild _pN where N is the number of patches on the 'bugs' page.
- my_patch_index=1
- while [[ ${my_patch_index} -le ${MY_PATCH} ]] ; do
- SRC_URI+=" "
- SRC_URI+=$(printf "https://www.mpfr.org/${MY_P}/patch%02d -> ${MY_P}-patch%02d.patch " ${my_patch_index} ${my_patch_index})
- my_patch_index=$((my_patch_index+1))
+ for ((my_patch_index=1; my_patch_index <= MY_PATCH; my_patch_index++)); do
+ SRC_URI+=" $(printf "https://www.mpfr.org/${MY_P}/patch%02d -> ${MY_P}-patch%02d.patch " ${my_patch_index}{,})"
+ MY_PATCHES+=( "${DISTDIR}"/$(printf ${MY_P}-patch%02d.patch ${my_patch_index}) )
done
unset my_patch_index
fi
@@ -42,15 +42,20 @@ IUSE="static-libs"
RDEPEND=">=dev-libs/gmp-5.0.0:=[${MULTILIB_USEDEP},static-libs?]"
DEPEND="${RDEPEND}"
-PATCHES=()
+PATCHES=(
+ # Apply the upstream patches released out-of-band; generated above
+ "${MY_PATCHES[@]}"
-if [[ ${PV} == *_p* ]] ; then
- # Apply the upstream patches released out of band
- PATCHES+=( "${DISTDIR}"/ )
-fi
+ # Additional patches
+)
HTML_DOCS=( doc/FAQ.html )
+src_unpack() {
+ # Avoid src_unpack noise from patches
+ unpack ${MY_P}.tar.xz
+}
+
src_prepare() {
default
@@ -61,9 +66,9 @@ src_prepare() {
}
multilib_src_configure() {
- # bug 476336#19
+ # bug #476336#19
# Make sure mpfr doesn't go probing toolchains it shouldn't
- ECONF_SOURCE=${S} \
+ ECONF_SOURCE="${S}" \
user_redefine_cc=yes \
econf $(use_enable static-libs static)
}