summaryrefslogtreecommitdiff
path: root/dev-libs/modsecurity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-26 06:14:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-26 06:14:16 +0100
commitd5d36fc823b7189d033e69314ae2764f1eed9168 (patch)
tree7ad153046482fd6c121d0654933c134a72aab4d6 /dev-libs/modsecurity
parent81a92c310907a51d2a03b6d470f4276a7d7ac00c (diff)
gentoo auto-resync : 26:04:2023 - 06:14:16
Diffstat (limited to 'dev-libs/modsecurity')
-rw-r--r--dev-libs/modsecurity/Manifest2
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.9.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/modsecurity/Manifest b/dev-libs/modsecurity/Manifest
index 3b43e0867ef9..6df4840080c8 100644
--- a/dev-libs/modsecurity/Manifest
+++ b/dev-libs/modsecurity/Manifest
@@ -1,3 +1,5 @@
DIST modsecurity-v3.0.8.tar.gz 3336288 BLAKE2B de15124362f23c86a6dcee15dd847fcf703a378a57ebd4826a6304fed33b34f4791c7aa80abd42cbe5932063c1ca59f755345e3810dcbc296e2b6a758e0c580b SHA512 8113358548aea19a18de183922e979fd7ce9daad289c6894bda458176f17da63fb45160a2a86d97730c90191c881b232b1c9c6ab9209c3988b4390e49e086117
+DIST modsecurity-v3.0.9.tar.gz 3337195 BLAKE2B 5de70546463b9cf167e8e3fd13c55b3856dbe4f23f94a8f83a65890a4e5ea990597a0bb00f4dc24a52a3eb36fe6fa80a8d4a857f86bff3db5808b0d0bdd82b03 SHA512 49790031a82a6cece9cf53a03480490c0bdfd56302ea2e55319a27abdadf1aee060d4a9f847b224a21533d24f6a9fc29b4ad3898b258e6a81934a03c00e32020
EBUILD modsecurity-3.0.8.ebuild 1471 BLAKE2B 319d98a2631dfd4ac9870db77033bfb8c6b8b8320cc062c1632aebf6f085aa47974dc5f31a4eaef923b0aa6623b8fb64314147d2a69bd3dbb07e1fd15f03ec1e SHA512 50b3e66c5160689d20b52223a45cbebaaa2820474ada5b0c4bfef3348f352f7b1bd15b1c903d8cc2202bdd1f447fed9cf67a1c6159967e3c65292e08c2703994
+EBUILD modsecurity-3.0.9.ebuild 1475 BLAKE2B a59f762e5a93b0d3807d5b9cf178563953e6b852f1ab3699aed7ca0cff16c1c8ea44871dbe6dfcb1cea3210c3e8556d368e53353537661f0ed9df2844609af36 SHA512 a6be5ca50bdbb2a521ea94174fe6d37d0911784fd53e8a1d3493dd732187884aab2fe5bd81154a6708cf316e8c65dc3259e8d148b8d96b1975500cd1ce44fd05
MISC metadata.xml 1019 BLAKE2B 0873fbb1c328dea3378abbe280dc7adacf389a9f1085614057e328ca7258afb4553c2a37bb527eb80b995d69e428ac7fcb3306e65a84c0e3d17acb6ace270b0b SHA512 549b1dc80684fff950148598807b866ab9400c619d2ecb32f2e7f90f8f298dd47daadd4c33f76af40983ed22ffbbb017c110253d810bab931344dd6f80d8f2ce
diff --git a/dev-libs/modsecurity/modsecurity-3.0.9.ebuild b/dev-libs/modsecurity/modsecurity-3.0.9.ebuild
new file mode 100644
index 000000000000..d450dca9e74d
--- /dev/null
+++ b/dev-libs/modsecurity/modsecurity-3.0.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Application firewall and intrusion detection"
+HOMEPAGE="https://github.com/SpiderLabs/ModSecurity"
+SRC_URI="https://github.com/SpiderLabs/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RDEPEND="dev-libs/libpcre:=
+ dev-libs/libxml2
+ net-misc/curl
+ fuzzyhash? ( app-crypt/ssdeep )
+ geoip? ( dev-libs/geoip )
+ geoip2? ( dev-libs/libmaxminddb )
+ json? ( dev-libs/yajl )
+ lmdb? ( dev-db/lmdb )
+ lua? ( ${LUA_DEPS} )
+ pcre2? ( dev-libs/libpcre2:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with fuzzyhash ssdeep)
+ $(use_with geoip )
+ $(use_with geoip2 maxmind)
+ $(use_with json yajl)
+ $(use_with lmdb)
+ $(use_with lua)
+ $(use_with pcre2)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc && doxygen doxygen.cfg || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/html
+ find "${ED}" -name '*.la' -delete || die
+}