summaryrefslogtreecommitdiff
path: root/dev-libs/miniz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/miniz
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/miniz')
-rw-r--r--dev-libs/miniz/Manifest3
-rw-r--r--dev-libs/miniz/metadata.xml20
-rw-r--r--dev-libs/miniz/miniz-2.1.0.ebuild29
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/miniz/Manifest b/dev-libs/miniz/Manifest
new file mode 100644
index 000000000000..c5728404a647
--- /dev/null
+++ b/dev-libs/miniz/Manifest
@@ -0,0 +1,3 @@
+DIST miniz-2.1.0.tar.gz 104502 BLAKE2B 9a7b3818b454809cdfec523d98f13bef3a52e27b6d3857d289438978d12997e38c71aa97fffe060a6b765f8fbbdd8fe8cebced4a45d9f1f040dd3e39cf2a8055 SHA512 e0aba16afdf230d1e54d0a9cedd336b0b158b02744839f0547e14ee47a97fc1a6668f3a181bd46e969b01b158af18dc8ed3c0a4210b3b620242338a2788806b3
+EBUILD miniz-2.1.0.ebuild 636 BLAKE2B 517fbd2edb6ed5c3a7441f04e13a430f3099bd1bc5a494e1b20a96e17bebe37d58960da22412af2f642000f918b0101bbc7322f2f7d2097e0f2740dce03b6aaf SHA512 df07a3b77e72ec2f07178655e3cf4c3424440e14a081332e9437661316607ccc44a327e0acab7f4a3bdddb2518710c4e7c3104527a249ebf87d6ebe476a6d8a3
+MISC metadata.xml 1067 BLAKE2B 4360a8656cd006529dd8955d1905daa17e2a51c2ec5dabe6bc692ebdca70ca2a06d588d9e6dc6989c773922172e32ded9a7c1d65e41907468a2df5d1f18b1abc SHA512 8e36cbda8ad79dccaf7cd95eb9675e306c276d2173b0e1944d21b924f518ab0085fc4262eafa23aa3870633f198d8622b1d05866336b5551111b8750f16f220c
diff --git a/dev-libs/miniz/metadata.xml b/dev-libs/miniz/metadata.xml
new file mode 100644
index 000000000000..8cf9d7cdd9de
--- /dev/null
+++ b/dev-libs/miniz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Miniz is a lossless, high performance data compression library in a single source file that implements the zlib
+ (RFC 1950) and Deflate (RFC 1951) compressed data format specification standards. It supports the most commonly
+ used functions exported by the zlib library, but is a completely independent implementation so zlib's licensing
+ requirements do not apply. Miniz also contains simple to use functions for writing .PNG format image files and
+ reading/writing/appending .ZIP format archives. Miniz's compression speed has been tuned to be comparable to
+ zlib's, and it also has a specialized real-time compressor function designed to compare well against
+ fastlz/minilzo.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">richgel999/miniz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/miniz/miniz-2.1.0.ebuild b/dev-libs/miniz/miniz-2.1.0.ebuild
new file mode 100644
index 000000000000..1141b3f020ce
--- /dev/null
+++ b/dev-libs/miniz/miniz-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
+HOMEPAGE="https://github.com/richgel999/miniz"
+SRC_URI="https://github.com/richgel999/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( ChangeLog.md LICENSE readme.md )
+
+src_prepare() {
+ sed -i -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+
+ cmake_src_configure
+}