summaryrefslogtreecommitdiff
path: root/dev-libs/mini-xml/mini-xml-2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-libs/mini-xml/mini-xml-2.11.ebuild
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-libs/mini-xml/mini-xml-2.11.ebuild')
-rw-r--r--dev-libs/mini-xml/mini-xml-2.11.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/mini-xml/mini-xml-2.11.ebuild b/dev-libs/mini-xml/mini-xml-2.11.ebuild
deleted file mode 100644
index 6a29195944da..000000000000
--- a/dev-libs/mini-xml/mini-xml-2.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_P="${P/mini-xml/mxml}"
-
-DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
-HOMEPAGE="https://github.com/michaelrsweet/mxml
- https://www.msweet.org/mxml/"
-SRC_URI="https://github.com/michaelrsweet/mxml/releases/download/v${PV}/${MY_P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="Mini-XML"
-SLOT="0"
-IUSE="static-libs test threads"
-
-DEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}"
-
-PATCHES=( "${FILESDIR}"/respect-users-flags.patch )
-
-src_prepare() {
- default
-
- eautoconf
-}
-
-src_configure() {
- local myeconfopts=(
- $(use_enable threads)
- )
-
- econf "${myeconfopts[@]}"
-}
-
-src_compile() {
- emake libmxml.so.1.6 doc/mxml.man mxmldoc
-}
-
-src_test() {
- emake testmxml
-}
-
-src_install() {
- emake DSTROOT="${ED}" install
-
- if ! use static-libs; then
- rm "${ED%/}"/usr/$(get_libdir)/libmxml.a || die
- fi
-}