summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
commit84dcbb8bcdcf5785ac3b24905c73ae4aa6bb781e (patch)
tree6f6b979013e5661ca4b3690bc9417307fdc169ce /dev-libs/mimalloc
parent57e62db33bb33adb6593a2be7b3a5990aaf01f56 (diff)
gentoo auto-resync : 16:11:2022 - 00:53:49
Diffstat (limited to 'dev-libs/mimalloc')
-rw-r--r--dev-libs/mimalloc/Manifest4
-rw-r--r--dev-libs/mimalloc/metadata.xml3
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.7.ebuild30
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index 112b5fd65197..9ec8ffa94261 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1,3 +1,5 @@
DIST mimalloc-2.0.6.tar.gz 1127052 BLAKE2B bd8a38cc0eab6ad950a63f494f24e6a91c50d2104335e9ce70963a7baadd26c7a2b7440b2fcabe502d9961549222873d017cb525bf5b32da967cf51aa167603c SHA512 f2fc0fbfb6384e85959897f129e5d5d9acc51bda536d5cabcd7d4177dbda9fb735b8a8c239b961f8bea31d37c9ae10f66da23aa91d497f95393253d4ac792bb3
+DIST mimalloc-2.0.7.tar.gz 1137057 BLAKE2B dc7ca7443507b14967168e4899464d137da425bdbc3863d44faef7adfe62e983cec0a7950937f010d003ff4df3c4368ff2f9753c3fda19641ab12f91fc73055c SHA512 120f89eef50ba83130e8ceb974a6148c84a7f3d975d1efaa094142518afb4ff6d9e24f8e75e9aa0bb02dc80bf497eced4b8ae1f2f5914fdabd773317e1341ea1
EBUILD mimalloc-2.0.6.ebuild 705 BLAKE2B 061a28d98c9524f5be76ceba0527dce233384a9e70516897473af9b3c4bb37c16f87d0c7ee9066c1550ce563016e6825940310b7dba3d50e5d1d4a1b1d9d5694 SHA512 55875ceea8d50f807a2446be938a4d931b25de1d9d32dfcd55aeff4e88a82649a563100a74e50c552b93ed318314228e7ae8160eae4d9ab26523334fa4abdf4d
-MISC metadata.xml 431 BLAKE2B 6b4122d0fc6609b5ee6d4fd345727301fdf1bf0943507240002d4a574aeb84622a1be6af2f095d231c9d3da303de39485234b7136a91a2d819a5434859eeea35 SHA512 9506d3cd5946abbad9a051e8cda535d361040d015e57b3b0f73a7a144e63d88e972aa427d52373ddc96b60868ee5d21e0f74b6001332343f2f57971ee27e5ab4
+EBUILD mimalloc-2.0.7.ebuild 680 BLAKE2B fae71c25a7d847b9f4f51a514a536f297597057cd546901daeff374c2a09827964267427a80413505a5ef5b1937b151154eea12284e9887b28a03195c3fa69de SHA512 836958299d1aad7323ab4e8e1d62652f0a2b73ae8433a088e529739e846acfd3ca2bd395beeed5f36583a6588b5d0ce48977815642a128a33a7572e623cd6d7f
+MISC metadata.xml 504 BLAKE2B cf6477282968a5469d072cfd81ce800e3ef0a48deb5353c85a1cabc837560cafdb9f9739cb4e98784238d2cc512a29cae5efee401f92a19bf75fb5d810154f76 SHA512 4e8fcc49881f3c479424cf363665d9b12c58eb52f7d962b98b81f5b3e186ba3bd14c2b5dac488d819147121a16c2d9613e75cb77f71fa04e820ca2c1e538baa6
diff --git a/dev-libs/mimalloc/metadata.xml b/dev-libs/mimalloc/metadata.xml
index 465023490e6b..62ab55808822 100644
--- a/dev-libs/mimalloc/metadata.xml
+++ b/dev-libs/mimalloc/metadata.xml
@@ -9,6 +9,9 @@
<email>sam@gentoo.org</email>
<name>Sam James</name>
</maintainer>
+ <use>
+ <flag name="hardened">Enable exploit mitigations</flag>
+ </use>
<upstream>
<remote-id type="github">microsoft/mimalloc</remote-id>
</upstream>
diff --git a/dev-libs/mimalloc/mimalloc-2.0.7.ebuild b/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
new file mode 100644
index 000000000000..313ecbb034c5
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="hardened test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}