summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-25 06:11:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-25 06:11:53 +0100
commit821eeed50e2a80c0959b8199e364e838d285206c (patch)
treec234fb1f6c8f4cd1dbc6bb444e3ad9c6ef90eb7c /dev-libs/mimalloc/mimalloc-2.1.2.ebuild
parent3e837954479e3c2c67afb16e6d997cbd1526c77c (diff)
gentoo auto-resync : 25:04:2023 - 06:11:52
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.1.2.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.1.2.ebuild b/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
new file mode 100644
index 000000000000..5c8b6056d6ae
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hardened test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}