summaryrefslogtreecommitdiff
path: root/dev-libs/mathjax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/mathjax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/Manifest5
-rw-r--r--dev-libs/mathjax/mathjax-2.7.0.ebuild58
-rw-r--r--dev-libs/mathjax/mathjax-2.7.4.ebuild58
-rw-r--r--dev-libs/mathjax/metadata.xml23
4 files changed, 144 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
new file mode 100644
index 000000000000..234d04d9124b
--- /dev/null
+++ b/dev-libs/mathjax/Manifest
@@ -0,0 +1,5 @@
+DIST mathjax-2.7.0.tar.gz 24594403 BLAKE2B 7cadfe7565a7ebba3569fb298a097f07081926b843a06c3c32447757eb0a5d463d654f20c42821010c81c59819bb14fdc5e84a39e87106bb6808bd6c9ca52bb7 SHA512 2a7c2b4a4991485c18f78dda4115da05a31c1a2d952c403726e99d22fd26f166298199238ad482e53b63b5414be687f325b586f5ebe4e2d552447c929415b350
+DIST mathjax-2.7.4.tar.gz 25355532 BLAKE2B 0bed5224356757c64989de8b9355f5c2505f1fa951456c52caf1cc0a9b5a864633ce5299cc9b67b1e5c743e39bcb6aee787a76d6871fc998b614d62e12499f6f SHA512 cddc4c64c188620307f0ede3b0bc7ba071f78702ba6315426d8c83129543a6b81a3a9a115f88017e23b5094b7aefd934c39aeec9688419830e33f9fd0fb1de7e
+EBUILD mathjax-2.7.0.ebuild 1219 BLAKE2B d6a55b0baf2dece7e35e043db8be4f41cc3705b9a032ae18537e6d1a5abd21c179d428b7c6defb809de30505aefc62a04b60db93655fadea15cbe01f4371be68 SHA512 41c37e0d36ecc2ef1eff3936bd6b47d90644e6ad31f54d3276acde4a0bb15f8b1c169bdd749c59c8e0f1ae7f92681a5b68463a6b1a40d12dec1dab7b9f9df1a8
+EBUILD mathjax-2.7.4.ebuild 1222 BLAKE2B 99be4290bb4275d3f17d866c42b6ced052976cbe2d65329372399de077b0193aedf241e1c75e756524f58d7b3877cbed5c060be7796dd73084faaa15c2be0efc SHA512 f3096b882da3c70b5fbbc4c1a78d84fa107ae32806d26b977d15bde5738ea90d4638b6715b20aa0da1e5ea1c6e45ea688a771dd9969bd0edb3798c162c840f27
+MISC metadata.xml 1030 BLAKE2B 8f3b54b726e2f135394cd6a0957d309070d3aba8fa7c40ef4b51ef8daaa0123b7f30f6cc793e2d93cef3c9f801267640444d7c604a3d6dcb277d9621ec6dd1a7 SHA512 aa7911df581513457da3e6f146e9d7d986c9b028698309ed42d1980f7bdd7a738dd6eb2a252ffbdd49fded3877e196c32b0a75f90fd1fd928b078429ed84565e
diff --git a/dev-libs/mathjax/mathjax-2.7.0.ebuild b/dev-libs/mathjax/mathjax-2.7.0.ebuild
new file mode 100644
index 000000000000..e7c89b829bfe
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( README* )
+ use doc && local HTML_DOCS=( docs/html/* )
+ default
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r test/*
+ fi
+ rm -r test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}
diff --git a/dev-libs/mathjax/mathjax-2.7.4.ebuild b/dev-libs/mathjax/mathjax-2.7.4.ebuild
new file mode 100644
index 000000000000..5aaff1048750
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.7.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( README* )
+ use doc && local HTML_DOCS=( docs/html/* )
+ default
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r test/*
+ fi
+ rm -r test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}
diff --git a/dev-libs/mathjax/metadata.xml b/dev-libs/mathjax/metadata.xml
new file mode 100644
index 000000000000..02ddbd0ff229
--- /dev/null
+++ b/dev-libs/mathjax/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <longdescription lang="en">
+ MathJax is an open-source JavaScript display engine for LaTeX and
+ MathML that works in all modern browsers. It was designed with the
+ goal of consolidating the recent advances in web technologies into a
+ single, definitive, math-on-the-web platform supporting the major
+ browsers and operating systems. It requires no setup on the part of
+ the user (no plugins to downlaod or software to install), so the
+ page author can write web documents that include mathematics and be
+ confident that users will be able to view it naturally and
+ easily. One simply includes MathJax and some mathematics in a web
+ page, and MathJax does the rest.
+</longdescription>
+ <upstream>
+ <remote-id type="github">mathjax/MathJax</remote-id>
+ </upstream>
+</pkgmetadata>