summaryrefslogtreecommitdiff
path: root/dev-libs/mathjax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/mathjax
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/Manifest2
-rw-r--r--dev-libs/mathjax/mathjax-2.7.7.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
index 35df4e665c28..ba3ecc593068 100644
--- a/dev-libs/mathjax/Manifest
+++ b/dev-libs/mathjax/Manifest
@@ -1,5 +1,7 @@
DIST mathjax-2.7.0.tar.gz 24594403 BLAKE2B 7cadfe7565a7ebba3569fb298a097f07081926b843a06c3c32447757eb0a5d463d654f20c42821010c81c59819bb14fdc5e84a39e87106bb6808bd6c9ca52bb7 SHA512 2a7c2b4a4991485c18f78dda4115da05a31c1a2d952c403726e99d22fd26f166298199238ad482e53b63b5414be687f325b586f5ebe4e2d552447c929415b350
DIST mathjax-2.7.4.tar.gz 25355532 BLAKE2B 0bed5224356757c64989de8b9355f5c2505f1fa951456c52caf1cc0a9b5a864633ce5299cc9b67b1e5c743e39bcb6aee787a76d6871fc998b614d62e12499f6f SHA512 cddc4c64c188620307f0ede3b0bc7ba071f78702ba6315426d8c83129543a6b81a3a9a115f88017e23b5094b7aefd934c39aeec9688419830e33f9fd0fb1de7e
+DIST mathjax-2.7.7.tar.gz 25347766 BLAKE2B c1f11bc854c95888d7f04ee627094a2e297e7554b0380dab30c08e2c4405495df611b440da0efd1e6456150513e07fa4ef90808d2332f9fb83785c118228de18 SHA512 471bd22475827a13d79de7d335f3e51ace06dfc04f575e8829b4505f428949f1dbe58798635cb434ed02ae0cd3fd8d1d577196b4961365fbcb399cc075d3284f
EBUILD mathjax-2.7.0.ebuild 1219 BLAKE2B d6a55b0baf2dece7e35e043db8be4f41cc3705b9a032ae18537e6d1a5abd21c179d428b7c6defb809de30505aefc62a04b60db93655fadea15cbe01f4371be68 SHA512 41c37e0d36ecc2ef1eff3936bd6b47d90644e6ad31f54d3276acde4a0bb15f8b1c169bdd749c59c8e0f1ae7f92681a5b68463a6b1a40d12dec1dab7b9f9df1a8
EBUILD mathjax-2.7.4.ebuild 1216 BLAKE2B 0ccca9312eb6aaaf82c31387f9fbc67a160a2620af79dc0f20e8bc246920da424a1c837a4d14678252427d8a06120d2e50767bb25b8d4325f7b8d90783fc2ea9 SHA512 b1d85236a3348c80835a81a6b2d30727e0ab7eea24d813862f38d70f7b6c2e82852048dd93e649ad5412c3680e26d650ceec8636e9f9c8aab987c215b1641130
+EBUILD mathjax-2.7.7.ebuild 1342 BLAKE2B 9a1e6be03d053eaf6268911209571661a4804d08c20c7bab93869c07a690add946dcd785e0c18c13d5a6babf2f82d3077829d31fb61acb53a9b7aa1c3b2f9b18 SHA512 4bc6cc9a93c369b4685d746c9e2765e2aeaa1173e6f163ea2fdf9eda3a250bcb00772d056b30a65871f76b951fafd5fec71bad633d977877647964678f096b1d
MISC metadata.xml 1030 BLAKE2B 8f3b54b726e2f135394cd6a0957d309070d3aba8fa7c40ef4b51ef8daaa0123b7f30f6cc793e2d93cef3c9f801267640444d7c604a3d6dcb277d9621ec6dd1a7 SHA512 aa7911df581513457da3e6f146e9d7d986c9b028698309ed42d1980f7bdd7a738dd6eb2a252ffbdd49fded3877e196c32b0a75f90fd1fd928b078429ed84565e
diff --git a/dev-libs/mathjax/mathjax-2.7.7.ebuild b/dev-libs/mathjax/mathjax-2.7.7.ebuild
new file mode 100644
index 000000000000..85f1f957063e
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.7.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-clean
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="doc? ( app-doc/mathjax-docs:${SLOT} )"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( README.md )
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ dosym ../${PN}-docs-${SLOT}/html /usr/share/doc/${P}/html
+ fi
+
+ default
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r test/*
+ fi
+ rm -r test docs LICENSE README.md || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}