summaryrefslogtreecommitdiff
path: root/dev-libs/ltxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/ltxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/ltxml')
-rw-r--r--dev-libs/ltxml/Manifest5
-rw-r--r--dev-libs/ltxml/ltxml-1.2.5.ebuild27
-rw-r--r--dev-libs/ltxml/ltxml-1.2.9.ebuild44
-rw-r--r--dev-libs/ltxml/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/ltxml/Manifest b/dev-libs/ltxml/Manifest
new file mode 100644
index 000000000000..5cfa48b34369
--- /dev/null
+++ b/dev-libs/ltxml/Manifest
@@ -0,0 +1,5 @@
+DIST ltxml-1.2.5.tar.gz 1081135 BLAKE2B 8029284317aca2655f66d5724e8662f0defab9f947b562b33be71cc61a75186fd9c51729619fb1a576e205b5d36d83f6040684fa92ffb3af36a60d90a36d9a26 SHA512 b8cb5a17a35748b3c3df25ea01b97d41443f34ae3e086fa8b13e46b10edb653ad66a236ec88350b85a1879135e899e097f067628afc4db294d04314d1fd85fcb
+DIST ltxml-1.2.9.tar.gz 304050 BLAKE2B 607fdcdfd056784862d06a7c6d3ea980695cff429f843235a0f5d8ce981996e1e3028cf5d7cf6329f208fabd7021ad15bd3e70efec8500d529d802e30994b18f SHA512 1c0b965b7ed330069a23259bc937546a6a0eb639206a844b6c4d524acfaeb1ec6978467fa8e63c8430ca222cec04386368e7ce625ac829ea5be445e880b86ac9
+EBUILD ltxml-1.2.5.ebuild 648 BLAKE2B 339c07048b00245310c9323d40f8cb21944034790cd464e113d3bd3b62abe253ef905a81de0ca1bfcf30487f98241be2c42a3782093685c2759f5142a6872f6d SHA512 2f3e1048be21328ac9c838fee15802f2cdefee1266b5c76dc05da355898ac45285a40388de4825fe32fdfdf5aa3d9a75e7d0699f9c640e7a037d2fc65ee6f169
+EBUILD ltxml-1.2.9.ebuild 851 BLAKE2B 99bd803aa2fd49977222423aae2fc14e8deb02f981bdc981fe1f975743cc359a052f9264d96057e8162b55c490524f7dd67041df39c1a6f13badb365b3b15f2f SHA512 0a79bba7a9e0bdcc5611d573e5b4165cd349c8e78252752f2a2def8ff3ea76a12c5b3884b4eab2ab139748e612405f626fabecb2f5c1b53c565e5a2935cfb88a
+MISC metadata.xml 268 BLAKE2B 4ca0567bdd97196b8cb1cc66ed554fbbd99823935bf9b58e52013f678c148193f52dadcd4487e6f38df45790c6bacaa30676c8bd25a7672992ffc9e805e24c19 SHA512 c70be371eec365e07f54ce32fced749e5137228fabd7e087427f1ed6a75f8a1eb0668f4587054ccf1ee29ab12a75fd2f52bd2bef5bf2c20e36db7993b01b1903
diff --git a/dev-libs/ltxml/ltxml-1.2.5.ebuild b/dev-libs/ltxml/ltxml-1.2.5.ebuild
new file mode 100644
index 000000000000..33e03e7ce2ba
--- /dev/null
+++ b/dev-libs/ltxml/ltxml-1.2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+S="${WORKDIR}/${P}/XML"
+DESCRIPTION="Integrated set of XML tools and a developers tool-kit with C API"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/${P}.tar.gz
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64 ppc x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+PV_MAJ="${PV:0:1}${PV:2:1}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake all || die "make failed"
+}
+
+src_install() {
+ einstall \
+ datadir=${D}/usr/lib/${PN}${PV_MAJ} \
+ MANDIR=${D}/usr/share/man \
+ || die "make install failed"
+}
diff --git a/dev-libs/ltxml/ltxml-1.2.9.ebuild b/dev-libs/ltxml/ltxml-1.2.9.ebuild
new file mode 100644
index 000000000000..09755c5e6811
--- /dev/null
+++ b/dev-libs/ltxml/ltxml-1.2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Integrated set of XML tools and a developers tool-kit with C API"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/${P}.tar.gz
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+PV_MAJ="${PV:0:1}${PV:2:1}"
+
+S=${WORKDIR}/${P}/XML
+
+pkg_setup() {
+ tc-export AR
+}
+
+src_prepare() {
+ sed -e '/CFLAGS=/s:-g::' \
+ -e '/CFLAGS=/s:-O2::' \
+ -i configure || die
+ sed -e 's/ar rv/$(AR) rv/' -i src/Makefile.sub.in || die
+}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ emake -j1 install \
+ datadir="${D}"/usr/$(get_libdir)/${PN}${PV_MAJ} \
+ libdir="${D}"/usr/$(get_libdir) \
+ prefix="${D}"/usr
+}
diff --git a/dev-libs/ltxml/metadata.xml b/dev-libs/ltxml/metadata.xml
new file mode 100644
index 000000000000..3ff7c54672fe
--- /dev/null
+++ b/dev-libs/ltxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>
+Integrated set of XML tools and a developers tool-kit with C API
+</longdescription>
+</pkgmetadata>