summaryrefslogtreecommitdiff
path: root/dev-libs/log4sh/log4sh-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/log4sh/log4sh-1.4.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/log4sh/log4sh-1.4.2.ebuild')
-rw-r--r--dev-libs/log4sh/log4sh-1.4.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/log4sh/log4sh-1.4.2.ebuild b/dev-libs/log4sh/log4sh-1.4.2.ebuild
new file mode 100644
index 000000000000..bb98dc57cf64
--- /dev/null
+++ b/dev-libs/log4sh/log4sh-1.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A flexible logging framework for shell scripts"
+HOMEPAGE="https://sourceforge.net/projects/log4sh"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="examples"
+
+RDEPEND="app-shells/bash"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ # testsuite needs USER variable
+ export USER="$(whoami)"
+ make test || die "make test failed"
+}
+
+src_install() {
+ insinto /usr/lib/log4sh
+ doins build/log4sh
+
+ dodoc doc/*.txt
+ dohtml doc/*.{html,css}
+
+ if use examples; then
+ docinto examples
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc src/examples/*
+ fi
+}
+
+pkg_postinst() {
+ elog "To use log4sh, have your script source /usr/lib/log4sh/log4sh"
+ elog "If you want to use remote logging, you should install package,"
+ elog "that provides netcat binary (for example - net-analyzer/netcat)"
+}