summaryrefslogtreecommitdiff
path: root/dev-libs/log4cplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/log4cplus
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/log4cplus')
-rw-r--r--dev-libs/log4cplus/Manifest4
-rw-r--r--dev-libs/log4cplus/files/log4cplus-1.2.0-fix-c++14.patch31
-rw-r--r--dev-libs/log4cplus/log4cplus-1.2.0.ebuild71
-rw-r--r--dev-libs/log4cplus/metadata.xml14
4 files changed, 0 insertions, 120 deletions
diff --git a/dev-libs/log4cplus/Manifest b/dev-libs/log4cplus/Manifest
deleted file mode 100644
index 93aaee788264..000000000000
--- a/dev-libs/log4cplus/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX log4cplus-1.2.0-fix-c++14.patch 897 BLAKE2B c4067272e84b2e442ef61c5468734ee985a9931171e7651242e79029dd6c5c6a9aae03fb9aa9a3ec9c1d391763c7acc7d57c794904636a261b2ebefda4986fe4 SHA512 9771a43add0af52417d67f54c991d637928d5f8340e90a786f2e9714cbc206e4ce6e7cc55face0f2ed0ed2c34e0a52bd922fa11978b85ffa48f02235df7c2de9
-DIST log4cplus-1.2.0.tar.bz2 629119 BLAKE2B f1b4629f7b6184b3f34f9d702c17487e113548cba46f5a25bb0f4972d7f3ce207310b25c94abea8cc1360591f7d0ac3d466075e584f25ce1968fee9d5b5c543a SHA512 2c3f16645051a230f9ec9a6ac689421efc4b51d5f40cb772e552bd199d2ad13c39d7e577cc63d51617555941412da166a6cda8861ee219154a953d9926aae626
-EBUILD log4cplus-1.2.0.ebuild 1683 BLAKE2B a19f50a56c22d195f2edcf15b178e747530bc29fa4ffa3c8452cd72a08c3582b53f7c0d81a08400d45b0703516db449abeb3f98c2b7c06c5a15c0b6018258e5b SHA512 71b2eb9df247609fb647d09ba464eb7743cf6886e5260bcf0f42965c36b977efb07a20493236b1d4a1c759b2b3aca75d5de9d07a17c5e75d25d1738b2c78b425
-MISC metadata.xml 749 BLAKE2B 896a9b8fb91d74d3ddcad1b2d775ad65cb0de33a16961fd96096ba7ab59cf624a83a01c13f1263f17eaeb8ee578474fe067ac1e13d2a0f991b1988081c325ce5 SHA512 9fd7d13a36875f50fa784dd61b775cda0834d8e76302b9e6a6fec6e843131b869831ce4d9eb5c93c6b3eb1c58bf3514b4d5b6c3ac9bf70c95cd877d28b29fa96
diff --git a/dev-libs/log4cplus/files/log4cplus-1.2.0-fix-c++14.patch b/dev-libs/log4cplus/files/log4cplus-1.2.0-fix-c++14.patch
deleted file mode 100644
index ccd6e1aadd2e..000000000000
--- a/dev-libs/log4cplus/files/log4cplus-1.2.0-fix-c++14.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Make dtors noexcept(false) when compiling in C++11 and above. This avoids
-silent breakage due to the semantic changes between C++98 and C++11.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=595424
-
---- a/include/log4cplus/hierarchylocker.h
-+++ b/include/log4cplus/hierarchylocker.h
-@@ -48,7 +48,11 @@
- public:
- // ctor & dtor
- HierarchyLocker(Hierarchy& h);
-- ~HierarchyLocker();
-+ ~HierarchyLocker()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- /**
- * Calls the <code>resetConfiguration()</code> method on the locked Hierarchy.
---- a/src/hierarchylocker.cxx
-+++ b/src/hierarchylocker.cxx
-@@ -62,6 +62,9 @@
-
-
- HierarchyLocker::~HierarchyLocker()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- try {
- for(LoggerList::iterator it=loggerList.begin(); it!=loggerList.end(); ++it) {
diff --git a/dev-libs/log4cplus/log4cplus-1.2.0.ebuild b/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
deleted file mode 100644
index 07cf88b00eb3..000000000000
--- a/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="C++ port of the Log for Java (log4j) logging library"
-HOMEPAGE="http://log4cplus.sourceforge.net/ https://github.com/log4cplus/log4cplus"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}-stable/${PV}/${P}.tar.bz2"
-
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-SLOT="0/1.2-5"
-KEYWORDS="amd64 ~x86"
-IUSE="iconv qt5 threads working-locale working-c-locale"
-REQUIRED_USE="?? ( iconv working-locale working-c-locale )"
-
-RDEPEND="
- iconv? ( virtual/libiconv )
- qt5? ( dev-qt/qtcore:5 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}/${PN}-1.2.0-fix-c++14.patch" )
-
-src_configure() {
- # bug 648714
- # Qt5 now requires C++11
- append-cxxflags -std=c++11
-
- econf \
- --disable-static \
- $(use_with iconv) \
- $(use_with qt5) \
- $(use_enable threads) \
- $(use_with working-locale) \
- $(use_with working-c-locale)
-}
-
-src_test() {
- cd tests/ || die
-
- local t
- for t in appender customloglevel fileappender filter \
- hierarchy loglog ndc ostream patternlayout performance priority \
- propertyconfig timeformat; do
- einfo "Running test \"${t}_test\""
- pushd "${t}_test/" >/dev/null || die
- "${S}"/${t}_test || die "Running ${t}_test failed!"
- popd >/dev/null || die
- done
-
- if use threads; then
- for t in configandwatch thread; do
- einfo "Running test \"${t}_test\""
- pushd "${t}_test/" >/dev/null || die
- "${S}"/${t}_test || die "Running ${t}_test failed!"
- popd >/dev/null || die
- done
- fi
-}
-
-src_install() {
- default
- dodoc docs/unicode.txt
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/dev-libs/log4cplus/metadata.xml b/dev-libs/log4cplus/metadata.xml
deleted file mode 100644
index ccbce42becd1..000000000000
--- a/dev-libs/log4cplus/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="working-locale">Use C++'s std::locale for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation</flag>
- <flag name="working-c-locale">Use the C99 locale facilities for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation </flag>
- <flag name="iconv">Use inconv for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation</flag>
- </use>
- <upstream>
- <remote-id type="github">log4cplus/log4cplus</remote-id>
- <remote-id type="sourceforge">log4cplus</remote-id>
- </upstream>
-</pkgmetadata>