summaryrefslogtreecommitdiff
path: root/dev-libs/link-grammar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
commit71d582d27eeece574ab3d904aa3fbe7742b0e895 (patch)
treea859a9d4a94b41c113fb5bdb5c4ffe261d884970 /dev-libs/link-grammar
parent0b82ae29b3034efe3e7b7f533dbcb76168544c5e (diff)
gentoo auto-resync : 25:03:2023 - 12:50:15
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/Manifest2
-rw-r--r--dev-libs/link-grammar/link-grammar-5.12.3.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-libs/link-grammar/Manifest b/dev-libs/link-grammar/Manifest
index 1ed59096451d..44dab88431e4 100644
--- a/dev-libs/link-grammar/Manifest
+++ b/dev-libs/link-grammar/Manifest
@@ -1,3 +1,5 @@
DIST link-grammar-5.12.0.tar.gz 4688144 BLAKE2B 3ab74bcd23118c1d933895ac5ac8f042448f173234db1528de496e2f4aa88cd9b96d4783e54584f05d8af5bb835fee1f62f039ed883e2b24511198526d334dbd SHA512 1938e53a2d8bdb5d0c352e9bb7108b280d3c4da890f540f41bdc257eea1ea6de5712f99602fc0f4187654540e1142b5216efb2a8c9957f32ce0dec86d85ec3cb
+DIST link-grammar-5.12.3.tar.gz 4704751 BLAKE2B a7f0fe39c51ed26ea764d583b38b21cfce6e596c6cd94db6ba47b3606a2b6cd9e56bd6fedeb104dbb345baedae3e144af96999739dda9daa9a9e5886bd98d2f4 SHA512 e0fdb78ec03042119011afea005a62829317fd0bc20afcd94e3f234c9c5252ed9c57d717b75368ac4a63dd8493bd86f551870299925f3b9b95b11915f48d8abe
EBUILD link-grammar-5.12.0.ebuild 2783 BLAKE2B d730fdb43ecb501e2161448874818f420a606d1c1b97a86205864f37145c3811ac9d154bcef2181a1679402210d1d321f0b7d9c4c5700f9dc0629ca585776d8a SHA512 8beae468767a3e61216e3f1213c0a38c7f665b73b4581c3eaef48e2bb4680f11f226ad05bd8d34a7e1e8728628d9484d1afc263bf7c296e15aeb78cd71630792
+EBUILD link-grammar-5.12.3.ebuild 2779 BLAKE2B 431729b790fda8a8f04ae78bec9a472d4d99a3c09f555cf8e75a442df38bba0516289e440e0a88608e7b726de9a08d8af8d6c13492650fecf443dc3a79143a72 SHA512 00427fae3f9ea94582ba64fd9528c0784e7282d3bf45ead8343fb2fd163dcf5a5a0789a9b47f7b8657be003538fb7253d61888343319f809925846cd76255123
MISC metadata.xml 1197 BLAKE2B fac6dd40856d97100ee06cdcd340e660bb2ffe527df31983165beec9d194839336dfddb54be33561560ac2c79d8bad12809eef53abd4059b7c74b7494d728354 SHA512 dcb16b8afa977639e3fe8633762fc7a26d8ab095da15d630bedc6ba65e4c82ec5f0bedbd564b6ad0490790723c0a04065a5cab536aff93cdcf8eab5f1a2d503e
diff --git a/dev-libs/link-grammar/link-grammar-5.12.3.ebuild b/dev-libs/link-grammar/link-grammar-5.12.3.ebuild
new file mode 100644
index 000000000000..8a81b91fda91
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-5.12.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools python-r1 out-of-source
+
+DESCRIPTION="A Syntactic English parser"
+HOMEPAGE="https://www.abisource.com/projects/link-grammar/ https://www.link.cs.cmu.edu/link/"
+SRC_URI="https://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="aspell +hunspell python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# XXX: sqlite is automagic
+# Does not build with >=sci-mathematics/minisat-2, bug #593662
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/libpcre2:=
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+ python? ( ${PYTHON_DEPS} )
+ !sci-mathematics/minisat"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use aspell && use hunspell; then
+ ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
+ ewarn "only hunspell will be built. Press Ctrl+C and set only 'aspell' USE flag if"
+ ewarn "you want aspell support."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ local myconf=(
+ --disable-maintainer-mode
+ --disable-editline
+ # java is hopelessly broken, invokes maven at build time (bug #806157)
+ --disable-java-bindings
+ --disable-perl-bindings
+ --disable-sat-solver
+ --with-regexlib=pcre2
+ $(use_enable aspell)
+ $(use_enable hunspell)
+ $(usev hunspell --with-hunspell-dictdir="${EPREFIX}"/usr/share/myspell)
+ )
+
+ econf \
+ --disable-python-bindings \
+ "${myconf[@]}"
+
+ if use python; then
+ python_configure() {
+ econf \
+ --enable-python-bindings \
+ "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+my_src_compile() {
+ local -x MAIN_BUILD_DIR="${BUILD_DIR}"
+ default
+
+ if use python; then
+ python_compile() {
+ emake -C bindings/python \
+ VPATH="${S}:${MAIN_BUILD_DIR}" \
+ _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la
+ }
+ python_foreach_impl run_in_build_dir python_compile
+ fi
+}
+
+my_src_install() {
+ local -x MAIN_BUILD_DIR="${BUILD_DIR}"
+ default
+
+ if use python; then
+ python_install() {
+ emake -C bindings/python \
+ VPATH="${S}:${MAIN_BUILD_DIR}" \
+ _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ DESTDIR="${D}" \
+ install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}