summaryrefslogtreecommitdiff
path: root/dev-libs/link-grammar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-libs/link-grammar
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/Manifest2
-rw-r--r--dev-libs/link-grammar/link-grammar-5.10.5.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-libs/link-grammar/Manifest b/dev-libs/link-grammar/Manifest
index 96f68b962dac..f86241892cad 100644
--- a/dev-libs/link-grammar/Manifest
+++ b/dev-libs/link-grammar/Manifest
@@ -1,4 +1,6 @@
AUX link-grammar-5.8.1-lld.patch 531 BLAKE2B e7a64032d8e8394205d4529e270bee1ec121a6b29b6a779e885cae825678679e521b2f4eb2bec6b6b6c8f1c5f311337c7b2e205a5cb1966538741e72b7e7cb37 SHA512 03dd3164c7626d70019851189fd35d7ecfcbc112b594dafc0c3390f0d533b67611838cd9207a486139f4e4c8ac78f81da87d0c00a0238ad417c90942bcaa2c6b
DIST link-grammar-5.10.4.tar.gz 4593602 BLAKE2B 0515aed27ae8df85ceddb9685ce90db2b6e7671235b9b445b6728b1ac417d6d43b3705566066ff9735fc98c32746342c224f2399bb0f2573784f20b5f998e7be SHA512 a215694f76e15286c478884ea8a13b32976d06ea45d10897dc1b303f256a2c0af94c9f90da26b314ce5e03009b494ab526c729b66f2b1ed46ff3e8b02cb6fd08
+DIST link-grammar-5.10.5.tar.gz 4637765 BLAKE2B d280a06492462725c9c62352b6bf4fb0a11a09b2b3049e41d9a078fa2ad37c8ef0f0e99e05039e355e81d127c168024068319a4fcf64caa840c00c165ed22f11 SHA512 09774f7ce01bc7ec9912162297c9b7be176e655b70981a147d53245c015f62581e7f45c005d0590d1a65e870e3c2ac4288517012fd9caa9887e4fd86d8e6aa05
EBUILD link-grammar-5.10.4.ebuild 2921 BLAKE2B a8f4961b5360995d58b9d52d15357717a038f417ecd61941007bd5aadb324f2bcee9b33d53a161ffa682c3bef7ea68f9813fb1c52abf2e3602f025a10f61959e SHA512 6fa2c1ab5d2140c425b3f68f59760dc61eed86dda635616a591bfb3860a2a0a57d41a1c3f0c688cd02a8e3401c7ae865505116c927f4a8da856b0bb475ca9bb6
+EBUILD link-grammar-5.10.5.ebuild 2923 BLAKE2B 8559d949ea26e420c97628d02f9f9ce5b467cc9339fdd59ab60c406af6807177ec2cb4f046d039d8e2d3fdb124320a7e6b53b121caef5524b7c0f719c97a5bb6 SHA512 635ebd792e697ac282ab9451c8e95dfe2e46064aa7f5919c5ee62927c347c77a1dc6739d2f09be266dbb39307aa7e955461250e215581e999ad3a8e40a971951
MISC metadata.xml 1069 BLAKE2B e657e7727730c54d4aee903c585378978a2adf7a3a6851e6995445afe64e966e48bc4bfab6e930449c288b3ffca3436b9fbe67e88f9e790739ff0c8a079a79e2 SHA512 ba898591c96b8d05601389837891f6cda7eece200c10e014e86e0189aeeb5a0d0c04327d348ce2d77fa3d72dbbe3eec5b96953ff6903bd9670f305886f869229
diff --git a/dev-libs/link-grammar/link-grammar-5.10.5.ebuild b/dev-libs/link-grammar/link-grammar-5.10.5.ebuild
new file mode 100644
index 000000000000..9cd72d301f29
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-5.10.5.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-r1 out-of-source
+
+DESCRIPTION="A Syntactic English parser"
+HOMEPAGE="https://www.abisource.com/projects/link-grammar/ https://www.link.cs.cmu.edu/link/"
+SRC_URI="https://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="aspell +hunspell python" # pcre
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# XXX: sqlite is automagic
+# Does not build with >=sci-mathematics/minisat-2, bug #593662
+# add pcre support: pcre? ( dev-libs/libpcre )
+RDEPEND="
+ dev-db/sqlite:3
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+ python? ( ${PYTHON_DEPS} )
+ !sci-mathematics/minisat"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.8.1-lld.patch )
+
+pkg_setup() {
+ if use aspell && use hunspell; then
+ ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
+ ewarn "only hunspell will be built. Press Ctrl+C and set only 'aspell' USE flag if"
+ ewarn "you want aspell support."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ local myconf=(
+ --disable-maintainer-mode
+ --disable-editline
+ # java is hopelessly broken, invokes maven at build time (bug #806157)
+ --disable-java-bindings
+ --disable-perl-bindings
+ --disable-static
+ --enable-sat-solver=bundled
+ $(use_enable aspell)
+ $(use_enable hunspell)
+ $(usev hunspell --with-hunspell-dictdir="${EPREFIX}"/usr/share/myspell)
+ # $(use_enable pcre regex-tokenizer)
+ # $(use_with pcre)
+ )
+
+ econf \
+ --disable-python-bindings \
+ "${myconf[@]}"
+
+ if use python; then
+ python_configure() {
+ econf \
+ --enable-python-bindings \
+ "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+my_src_compile() {
+ local -x MAIN_BUILD_DIR="${BUILD_DIR}"
+ default
+
+ if use python; then
+ python_compile() {
+ emake -C bindings/python \
+ VPATH="${S}:${MAIN_BUILD_DIR}" \
+ _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la
+ }
+ python_foreach_impl run_in_build_dir python_compile
+ fi
+}
+
+my_src_install() {
+ local -x MAIN_BUILD_DIR="${BUILD_DIR}"
+ default
+
+ if use python; then
+ python_install() {
+ emake -C bindings/python \
+ VPATH="${S}:${MAIN_BUILD_DIR}" \
+ _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
+ DESTDIR="${D}" \
+ install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}