summaryrefslogtreecommitdiff
path: root/dev-libs/light/light-1.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-libs/light/light-1.2.2-r1.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-libs/light/light-1.2.2-r1.ebuild')
-rw-r--r--dev-libs/light/light-1.2.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/light/light-1.2.2-r1.ebuild b/dev-libs/light/light-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..8ea699addebd
--- /dev/null
+++ b/dev-libs/light/light-1.2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools udev
+
+DESCRIPTION="A program to control backlights (and other hardware lights)"
+HOMEPAGE="https://github.com/haikarainen/light"
+SRC_URI="https://github.com/haikarainen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="udev"
+
+RDEPEND="acct-group/video"
+DEPEND="udev? ( virtual/libudev:= )
+ ${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-fcommon.patch"
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(usex udev --with-udev="/lib/udev/rules.d" "")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+
+ ewarn "To use light as a regular user you must be a part of the video group"
+}