summaryrefslogtreecommitdiff
path: root/dev-libs/libxslt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
commit933ed80ab9b645de54b16eeb7410c0a54f47574f (patch)
treed954e8a97c73506c33035766b9578ece5d31667f /dev-libs/libxslt
parent0b1a4d018ed7758b9e49f6e4b3b38304f91a8cf5 (diff)
gentoo auto-resync : 18:08:2022 - 08:34:07
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/Manifest4
-rw-r--r--dev-libs/libxslt/libxslt-1.1.36.ebuild124
-rw-r--r--dev-libs/libxslt/libxslt-9999.ebuild8
3 files changed, 131 insertions, 5 deletions
diff --git a/dev-libs/libxslt/Manifest b/dev-libs/libxslt/Manifest
index fa05e3eab189..a95dc8f577e5 100644
--- a/dev-libs/libxslt/Manifest
+++ b/dev-libs/libxslt/Manifest
@@ -1,4 +1,6 @@
DIST libxslt-1.1.35.tar.xz 1827548 BLAKE2B 9667a93e61f50098a512c1351bce2ee937fc5d29488d010b525122d28ffedc73e0930402f3df2d378161a031dc016a15f0f03bdc343f0c4aa5d0b5c454f8002d SHA512 9dd4a699235f50ae9b75b25137e387471635b4b2da0a4e4380879cd49f1513470fcfbfd775269b066eac513a1ffa6860c77ec42747168e2348248f09f60c8c96
+DIST libxslt-1.1.36.tar.xz 1591356 BLAKE2B 7cdb38b52295477dcf4c9fdecfb64bc8e770b37787b3f4522d6156838725f4ee506b6d58ec18d17adeb22c78aa62d0685e77ad23e72901d1083de4efef1ae0df SHA512 8a524d32fca18e8b108c1b300d1381c01a71a87dc72a09bc13613772c2836b1350d8caa0625782c6cadf953f7a15ce805718a754cef894ee77b20442fc10f5c8
EBUILD libxslt-1.1.35.ebuild 1913 BLAKE2B 6c68990defa39e6d04fc70b4a2f4f3d1e1e27a109f04fefa85c0973aa8f9bd4680311fb25c8878cd65b29afc51bb7f4c7cc8a294b17f8a0f7a1cb77307ccc184 SHA512 9975052b66a9d23e5e0ce4c5df5647a4a43ebf9509dfae2cb90968fead499b2e7f83e0e74eb7ef51b969c0c0b7c89d97a1d1e62aa32b2b1eab6c724806498d01
-EBUILD libxslt-9999.ebuild 2767 BLAKE2B a4360b67aa78e3573be93cc592e0d97da859840c18ba25dcdf277a1d06a4aa30f0b087d08f4200b14c59a11bbea3f87d421f12998be17209a62e12bc5f7db03d SHA512 03e7ecf6b5bbe7c05270fe907581370a51e880330a36325c95b75d0b40d0fdd1c2c5f199f65dabd6194027a3d2900a0dab90d9c2a66952a9397c566202ef94ef
+EBUILD libxslt-1.1.36.ebuild 2936 BLAKE2B d725f63af0542cbef7e1d1806a3b46040b7ebfa884f61337df0b1b26a3e0fddbd965fb96788a2317cd2775fdcf4c7eb1cefd61da1ed4ee40b35acbb030ca0e33 SHA512 6d97110b767322df85985dd037fb495d44b235a514bf6ff780eb4bf9642bc74b24cfa613f8b654b1fd093ccde9ca02b524638a5aac9d11ff6a51cc0d8b68a5b1
+EBUILD libxslt-9999.ebuild 2774 BLAKE2B 9ad743eeb27ad818fb0ccbc2198b88855d4f35348386b99606ca2b7e4f66501b1a15072a1a9c759777ff0d9e00b8d24a4dc081851bd9202767c0357894aa6518 SHA512 2f9055e43050325543460580137da2d85cd8b188c80f2aa5bd5096a5900f13c6fbdf0c6029cc99527dc9e7a81bc5abbce1e33a5ffb447f290e838402c436fb0c
MISC metadata.xml 458 BLAKE2B 75fd3316bf24367ed9748bf7fefd6ebc36811d1cef9606b9fd68155ef7412d192ebc3cc883a79f15210decb7ef7707ff82155ec2f04974c2dca84496660519a8 SHA512 9baf1253900f23539a78ef57cc03cca552eadeb92721517e2f3f54c3df72be8d364b30449ad433793c38a2c1872273231f0b3fe865b2ace2e605a1ae290c4f6b
diff --git a/dev-libs/libxslt/libxslt-1.1.36.ebuild b/dev-libs/libxslt/libxslt-1.1.36.ebuild
new file mode 100644
index 000000000000..6f198ac22606
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.36.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Note: Please bump this in sync with dev-libs/libxml2.
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit autotools python-r1 multilib-minimal
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libxslt"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxslt"
+ inherit git-r3
+else
+ inherit gnome.org
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crypt debug examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND=">=virtual/pkgconfig-1"
+RDEPEND="
+ >=dev-libs/libxml2-2.9.11:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xslt-config
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libxslt/xsltconfig.h
+)
+
+DOCS=( AUTHORS FEATURES NEWS README TODO )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ else
+ # Prefix always needs elibtoolize if not eautoreconf'd.
+ #elibtoolize
+
+ # Temporarily for Python 3.10 fix (version used for
+ # dist tarballs fails w/ "3.1" error)
+ # See https://gitlab.gnome.org/GNOME/libxslt/-/issues/72.
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ libxslt_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --without-python \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug) \
+ $(use_enable static-libs static) \
+ "$@"
+ }
+
+ # Build Python bindings separately
+ libxslt_configure --without-python
+
+ if multilib_is_native_abi && use python ; then
+ NATIVE_BUILD_DIR="${BUILD_DIR}"
+ python_foreach_impl run_in_build_dir libxslt_configure --with-python
+ fi
+}
+
+libxslt_py_emake() {
+ pushd "${BUILD_DIR}"/python >/dev/null || die
+
+ emake top_builddir="${NATIVE_BUILD_DIR}" "$@"
+
+ popd >/dev/null || die
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake all
+ fi
+}
+
+multilib_src_test() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake test
+ fi
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake \
+ DESTDIR="${D}" \
+ install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use examples ; then
+ rm -rf "${ED}"/usr/share/doc/${PF}/tutorial{,2} || die
+ rm -rf "${ED}"/usr/share/doc/${PF}/python/examples || die
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/dev-libs/libxslt/libxslt-9999.ebuild b/dev-libs/libxslt/libxslt-9999.ebuild
index bd5015b66924..f76f9910fa95 100644
--- a/dev-libs/libxslt/libxslt-9999.ebuild
+++ b/dev-libs/libxslt/libxslt-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Note: Please bump this in sync with dev-libs/libxml2.
PYTHON_COMPAT=( python3_{8..11} )
-inherit libtool python-r1 multilib-minimal
+inherit python-r1 multilib-minimal
DESCRIPTION="XSLT libraries and tools"
HOMEPAGE="https://gitlab.gnome.org/GNOME/libxslt"
@@ -14,8 +14,8 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxslt"
inherit autotools git-r3
else
- inherit gnome.org
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ inherit libtool gnome.org
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"