summaryrefslogtreecommitdiff
path: root/dev-libs/libxslt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 05:42:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 05:42:48 +0100
commit100b0ae24e9b0d0fb3071efea2078a3bdabe4e38 (patch)
tree637adb56b86839c41fcb217b9bbe37e022fa666d /dev-libs/libxslt
parent12de738b83927a4b71c3ad067edbb6279d15b368 (diff)
gentoo auto-resync : 10:05:2023 - 05:42:48
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/Manifest4
-rw-r--r--dev-libs/libxslt/libxslt-1.1.38.ebuild125
-rw-r--r--dev-libs/libxslt/libxslt-9999.ebuild2
3 files changed, 129 insertions, 2 deletions
diff --git a/dev-libs/libxslt/Manifest b/dev-libs/libxslt/Manifest
index 88a5f18888ed..6d28f54cc928 100644
--- a/dev-libs/libxslt/Manifest
+++ b/dev-libs/libxslt/Manifest
@@ -1,4 +1,6 @@
DIST libxslt-1.1.37.tar.xz 1588572 BLAKE2B 096d93dd7178bf4483207514b1435f5bf426eea4952ffab7cc00c3e85aa736534c4acb5377af9647aa77a0cd793205194509d997a7bb5cae692f65e326566cd8 SHA512 a4e477d2bb918b7d01945e2c7491c3a4aae799dc1602bbd13de55c8a5052e210a20bc45115347eae44473c8b1d03dbc5e4a2aa18c2218f1fdfd376d87cd501ca
+DIST libxslt-1.1.38.tar.xz 1576676 BLAKE2B 9397be8b223bd68b326b954fe6a749a269e969b4669747678715728f553916c23475232fc2894a5e4230e15b031981423adeb8f83407f4db8075a784c7e6a55b SHA512 2836bd2990b95680db0960ac4c465d0c6c28a293ad095a224c05021a1c8d2576a45e41da8947a31f4ef3e6ef368cbda65243661e311c9886c19694be5a7c9a8e
EBUILD libxslt-1.1.37-r1.ebuild 3151 BLAKE2B eec05aff36285f0fca2e1364e76ee7630dffc7cec41f91bd83dc85332fb6071823e4cc4c51ac4366f59239d500934d3b6c23efa3adeb8d1252ebab3ed70bc8de SHA512 4558ecd8d02ac7545a953ac27556b331eb9332bd49507e88564deb25769e60c177055619c0d2233ba6954c882eb749eeccf4ddb8cbd430bc7def098f3fcbba87
-EBUILD libxslt-9999.ebuild 2946 BLAKE2B 3715eca571a40046d06f00cb8234964fe399a8744d1d9833d29a82ef11d01ae3405770cc67b3d898f0ac9a5fecc4bd6009fe4962b46f1596960043d65b36223a SHA512 bad625c3849507a1e634cb51ac7567f6f41c7c66521c0bad7e23e7c2e66de3bacbd26a58b20bbba94d8c9a379836b10391c4f46ff6e79a5eb328888285395a2e
+EBUILD libxslt-1.1.38.ebuild 3116 BLAKE2B 4565527e4347d83e66b5840f1bdbfabf0611e32e920cc0d68224040dd405d3ee1321dd1055723dc7304b7a4bc7e2475101a742b586af18ac49b2184cc1efd794 SHA512 a5118fdc3391af70e7a4bf5c4d0788cb40e0e25fc0178a6d4008f34bee9374c12de322deffd287e91d104e6248bd8a28841c88a4b2ad99969c988f1715e0cdde
+EBUILD libxslt-9999.ebuild 2947 BLAKE2B e3745a62497c08c81d13ea455bc4166f1608c0913ecb9b17032eb6bcb1cac51b8739b023aa8e300e408951c8a726fb28061a0e63d844d87bf1b0dc51dc09b9fb SHA512 de16f83803749d70099008a10f719a0ca80d2866f8b2a15ac2e87f6f53a6036f9d5cef59860c57473c53066cf9d5f9ed80d677b209c4e98a9790771c23266021
MISC metadata.xml 519 BLAKE2B 19c44d930c1d6af33c7cd756ddd74fb29f93d37dc4953956011e8ff5a563caa119b8848ef8e47ca0e71ced4134b7dfc9092c89a14cf1000148e0383c01183ddc SHA512 6c5e8dcd014d9203f0f50ba2e11d3fd52d89f226ef2f4d1d39143347a8de4433e1f6fa30881f87701695438da263c13dad59230c957002aea2950da01eb66c00
diff --git a/dev-libs/libxslt/libxslt-1.1.38.ebuild b/dev-libs/libxslt/libxslt-1.1.38.ebuild
new file mode 100644
index 000000000000..79e567f3d663
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.38.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Note: Please bump this in sync with dev-libs/libxml2.
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit flag-o-matic python-r1 multilib-minimal
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libxslt"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxslt"
+ inherit autotools git-r3
+else
+ inherit libtool gnome.org
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crypt debug examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND=">=virtual/pkgconfig-1"
+RDEPEND="
+ >=dev-libs/libxml2-2.9.11:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xslt-config
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libxslt/xsltconfig.h
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ else
+ # Prefix always needs elibtoolize if not eautoreconf'd.
+ elibtoolize
+ fi
+}
+
+multilib_src_configure() {
+ # Remove this after upstream merge request to add AC_SYS_LARGEFILE lands:
+ # https://gitlab.gnome.org/GNOME/libxslt/-/merge_requests/55
+ append-lfs-flags
+
+ libxslt_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --without-python \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug) \
+ $(use_enable static-libs static) \
+ "$@"
+ }
+
+ # Build Python bindings separately
+ libxslt_configure --without-python
+
+ if multilib_is_native_abi && use python ; then
+ NATIVE_BUILD_DIR="${BUILD_DIR}"
+ python_foreach_impl run_in_build_dir libxslt_configure --with-python
+ fi
+}
+
+libxslt_py_emake() {
+ pushd "${BUILD_DIR}"/python >/dev/null || die
+
+ emake top_builddir="${NATIVE_BUILD_DIR}" "$@"
+
+ popd >/dev/null || die
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake all
+ fi
+}
+
+multilib_src_test() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake test
+ fi
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl run_in_build_dir libxslt_py_emake \
+ DESTDIR="${D}" \
+ install
+
+ # Hack until automake release is made for the optimise fix
+ # https://git.savannah.gnu.org/cgit/automake.git/commit/?id=bde43d0481ff540418271ac37012a574a4fcf097
+ python_foreach_impl python_optimize
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use examples ; then
+ rm -rf "${ED}"/usr/share/doc/${PF}/tutorial{,2} || die
+ rm -rf "${ED}"/usr/share/doc/${PF}/python/examples || die
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/dev-libs/libxslt/libxslt-9999.ebuild b/dev-libs/libxslt/libxslt-9999.ebuild
index cec46e76ee26..827b9edd5507 100644
--- a/dev-libs/libxslt/libxslt-9999.ebuild
+++ b/dev-libs/libxslt/libxslt-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Note: Please bump this in sync with dev-libs/libxml2.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-r1 multilib-minimal
DESCRIPTION="XSLT libraries and tools"