summaryrefslogtreecommitdiff
path: root/dev-libs/libxmlb/libxmlb-0.3.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
commit6e356edde093fb3589ab7a5859685e85c2873ab0 (patch)
tree5f17cc7bfbddda45678967fdc0a5f9f35fa9c02a /dev-libs/libxmlb/libxmlb-0.3.10.ebuild
parentacb0389058b8ef612d851b1ab54fa37376c4b7f7 (diff)
gentoo auto-resync : 16:09:2022 - 17:15:17
Diffstat (limited to 'dev-libs/libxmlb/libxmlb-0.3.10.ebuild')
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.10.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.3.10.ebuild b/dev-libs/libxmlb/libxmlb-0.3.10.ebuild
new file mode 100644
index 000000000000..cef612cdd587
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc introspection stemmer test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.9-no_installed_tests.patch
+)
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc gtkdoc)
+ $(meson_use introspection)
+ $(meson_use stemmer)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}