summaryrefslogtreecommitdiff
path: root/dev-libs/libxls/libxls-1.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
commit7288c6e5fa05acddbf692a5187d925ef85662b46 (patch)
tree54bfc06561e59d1ad1e6e7bdbd06b76fc4ba0d06 /dev-libs/libxls/libxls-1.6.2-r1.ebuild
parent5a1fb66df455454109e1de61d38b48f509dc68b8 (diff)
gentoo auto-resync : 18:04:2023 - 11:55:01
Diffstat (limited to 'dev-libs/libxls/libxls-1.6.2-r1.ebuild')
-rw-r--r--dev-libs/libxls/libxls-1.6.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libxls/libxls-1.6.2-r1.ebuild b/dev-libs/libxls/libxls-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..0ba177446fdc
--- /dev/null
+++ b/dev-libs/libxls/libxls-1.6.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A library which can read Excel (xls) files"
+HOMEPAGE="https://github.com/libxls/libxls"
+SRC_URI="https://github.com/libxls/libxls/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/8" # libxlsreader.so.8
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-asprintf.patch
+ "${FILESDIR}"/${PN}-1.6.2-gcc13.patch
+)
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}