summaryrefslogtreecommitdiff
path: root/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild')
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
index 025e69060d40..8c306a31e412 100644
--- a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
+++ b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
@@ -1,32 +1,35 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Small library to access XDG Base Directories Specification paths"
HOMEPAGE="https://github.com/devnev/libxdg-basedir"
SRC_URI="https://github.com/devnev/libxdg-basedir/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x64-macos ~x86-solaris"
-IUSE="doc static-libs"
+IUSE="doc"
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
-S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-buffer-overflow.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-buffer-overflow.patch"
+ default
eautoreconf
}
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_enable doc doxygen-html)
}
@@ -42,8 +45,9 @@ src_install() {
emake DESTDIR="${D}" install
if use doc; then
- dohtml -r doc/html/*
+ docinto html
+ dodoc -r doc/html/*
fi
- find "${D}" -type f -name '*.la' -delete
+ find "${ED}" -type f -name '*.la' -delete
}